summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-05-19 19:24:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-05-19 19:24:40 +0000
commitdde29d161bbe88f748206490eff56f9c732e33db (patch)
tree93b520e4acfd6f57fda29401c46128143a93342b
parentdev-python/send2trash: Enable py3.11 (diff)
downloadgentoo-dde29d16.tar.gz
gentoo-dde29d16.tar.bz2
gentoo-dde29d16.zip
dev-db/postgresql: Add zstd support in postgresql-15
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--dev-db/postgresql/postgresql-15_beta1-r1.ebuild (renamed from dev-db/postgresql/postgresql-15_beta1.ebuild)4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-db/postgresql/postgresql-15_beta1.ebuild b/dev-db/postgresql/postgresql-15_beta1-r1.ebuild
index 2d34467c1c25..a9f6faf6e7e5 100644
--- a/dev-db/postgresql/postgresql-15_beta1.ebuild
+++ b/dev-db/postgresql/postgresql-15_beta1-r1.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="https://www.postgresql.org/"
IUSE="debug doc icu kerberos ldap llvm lz4 nls pam
perl python +readline selinux +server systemd ssl static-libs tcl
- threads uuid xml zlib"
+ threads uuid xml zlib zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -49,6 +49,7 @@ ssl? ( >=dev-libs/openssl-0.9.6-r1:0= )
tcl? ( >=dev-lang/tcl-8:0= )
xml? ( dev-libs/libxml2 dev-libs/libxslt )
zlib? ( sys-libs/zlib )
+zstd? ( app-arch/zstd )
"
# uuid flags -- depend on sys-apps/util-linux for Linux libcs, or if no
@@ -155,6 +156,7 @@ src_configure() {
$(use_with xml libxml) \
$(use_with xml libxslt) \
$(use_with zlib) \
+ $(use_with zstd) \
$(use_enable nls)"
if use alpha; then
myconf+=" --disable-spinlocks"