summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 19:20:33 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:15:11 -0600
commitddff79cd5293d9fa3849ef15e4425affe44dc6b7 (patch)
tree8f97dc33746e6886961859cea9a8edb977af5833
parentdev-python/oslo-serialization: bup (diff)
downloadgentoo-ddff79cd.tar.gz
gentoo-ddff79cd.tar.bz2
gentoo-ddff79cd.zip
dev-python/oslo-i18n: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/oslo-i18n/Manifest1
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-3.12.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index 1cd8ba5b9009..c94931068702 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1,2 +1,3 @@
+DIST oslo-i18n-3.12.0.tar.gz 40514 SHA256 6add28cbbe8254838f7f131de0cf0f3761786d57e5fe5716a488260b725f58d3 SHA512 a19cfec1acb1461d6373ffe5c13c275ce50c4e817e613c3cccd56b90955d99088162089753fba3b3185ee44598013e965c030d011e56140f95958dc9bfec4b61 WHIRLPOOL 64aefcf366b18db65f54b9277c6946ef013e02f49ebae6c8066227324ed807e644a14c17fccd6b5359d6e7fbf49f4e29e2c6fdfeacc8eeac98c79b5816e6ba74
DIST oslo-i18n-3.5.0.tar.gz 36093 SHA256 5fff5f6ceabed9d09b18d83e049864c29eff038efbbe67e03fe68c49cc189f10 SHA512 156b28fa1db65a57a8db2744d72cb5db2706ec773746e676895121c0d6459f4806d826b76428841ee7124c27eba281095fa50d64cbb68f82133c41560ea15950 WHIRLPOOL 8d599b0e989c650d305c0f2ad85596971e6b0e3c5a8f8daa00ba76b9fdc8cdf5486a346343123247efc8dbaf4d7825a62b5340a957c7e7881c2483ea051e90e1
DIST oslo-i18n-3.9.0.tar.gz 35973 SHA256 0bcb8108cf38b9ad4feb1ee08d27e34dc358f80dc7a7fe9a5b942ebf3b07c0b5 SHA512 7c176b8ac3ef0b52b2a08a7779c59b01fd32e084b99562eb232f9894ba4c9ae0bd810721fcf6fedf8729e3fdbfebce8b6210698aa0ae9e003855c8f2d66f2b0a WHIRLPOOL 34781968918cf6e7114301f7122f9d8f516be9f2db89798e64ad4589eb78f9b4a11e0f30b034b697734cfa3508cd997f13e8afe4b4abbc970d1705b42b060842
diff --git a/dev-python/oslo-i18n/oslo-i18n-3.12.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-3.12.0.ebuild
new file mode 100644
index 000000000000..9e491d0120d8
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-3.12.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}