summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2018-08-25 20:09:12 +0200
committerDavide Pesavento <pesa@gentoo.org>2018-08-25 20:11:04 +0200
commitde10fbaea9b11d0d9fe6d31179677d085e468add (patch)
treebaef842431015effa52ba828398611d1fef58be4
parentmedia-libs/nas: stable 1.9.4-r2 for ia64, bug #664320 (diff)
downloadgentoo-de10fbae.tar.gz
gentoo-de10fbae.tar.bz2
gentoo-de10fbae.zip
dev-python/qscintilla-python: remove 2.10.3
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--dev-python/qscintilla-python/Manifest1
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.10.3.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/qscintilla-python/Manifest b/dev-python/qscintilla-python/Manifest
index 4f7edbb1cb06..9726cb430a4c 100644
--- a/dev-python/qscintilla-python/Manifest
+++ b/dev-python/qscintilla-python/Manifest
@@ -1,2 +1 @@
-DIST QScintilla_gpl-2.10.3.tar.gz 2721287 BLAKE2B cc85eea17e563ae5f4a130d26ca88bec3e1a6cbff7bc0af096c63789384d03149105641d6324f53b37a2bd8ab4681a285ccb76e6063a06e5db30d070d3fd8219 SHA512 a1b9d6869797ec074e4e0727164804779792fb77b2230aae80e6d6b5fb3a3ff9d84e17d775d18ab74c97b78bac454511fd2cb49be1fa36f71d9097abf88045b6
DIST QScintilla_gpl-2.10.4.tar.gz 2721322 BLAKE2B df50dd0a34db96dd57147ddc399d4a30751b1bb4922dc1b8b3c3c1989e810937dc8345f92128e8a606b1edc04fde4b930a424ab8344818c9899c8fe496793a77 SHA512 dee6684f68173784d098931554c839a30e129b89f980cd9704f818c44eb7023199bd3682e4b342091fa3e0ce577ec576d34046477bdd1d7fc58ca5dd2ba947a3
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.10.3.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.10.3.ebuild
deleted file mode 100644
index f683ef80e872..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.10.3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit python-r1 qmake-utils
-
-MY_P=QScintilla_gpl-${PV/_pre/.dev}
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
-SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE="debug"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- ${PYTHON_DEPS}
- >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,printsupport,widgets,${PYTHON_USEDEP}]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwidgets:5
- ~x11-libs/qscintilla-${PV}:=
-"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}/Python
-
-src_configure() {
- configuration() {
- # Fix out-of-source build and installation of .sip files
- ln -s "${S}"/sip || die
-
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- --pyqt=PyQt5
- --qmake="$(qt5_get_bindir)"/qmake
- --sip-incdir="$(python_get_includedir)"
- $(usex debug '--debug --trace' '')
- --verbose
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- # Run eqmake to respect toolchain, build flags, and prevent stripping
- eqmake5 -recursive
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake INSTALL_ROOT="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-}