summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 05:37:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 05:37:44 +0200
commitde12333bc76e39f47126e685a2b23409b6e2a9c0 (patch)
tree716239461b8919b7450b65c5070d98a8d9056fcd
parentdev-python/types-psutil: Bump to 5.9.5.20240516 (diff)
downloadgentoo-de12333bc76e39f47126e685a2b23409b6e2a9c0.tar.gz
gentoo-de12333bc76e39f47126e685a2b23409b6e2a9c0.tar.bz2
gentoo-de12333bc76e39f47126e685a2b23409b6e2a9c0.zip
dev-python/mkdocstrings-python: Bump to 1.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mkdocstrings-python/Manifest1
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.10.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index f01953616eb2..8bb1747be9e9 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1,2 +1,3 @@
DIST mkdocstrings-python-1.10.0.gh.tar.gz 150022 BLAKE2B fc75c3a797a8c473121b6f00c17ff6b876170d2efde2a7c541667cdbdb1c730d3f843ed6c795d9a1ae8ceb22e56c50d91a0b7e29f4d6ec7aa1eb0f46e7a3c0a6 SHA512 743cadbf0c4318001a265b114d380107b3ed57b0b2ba4e73eb698a1e12074ba6bfe11277a4d245614226913d029483281058b1bc865a67f63de59698b89735dc
DIST mkdocstrings-python-1.10.1.gh.tar.gz 157475 BLAKE2B a31c75a27e8459791fa0958373da731a13ae6c1d04f8f170aa1a01046488ca1e289871ff3d7f9eca0f5ee4ce6a58ee24e0fc4005b8742b64d600cb391bb69bc2 SHA512 f020ca43cd22f36008da6491c9632d272b2928ab7d79e83222da6aa894fcd51f1cf608dfb881569e1e04881a533680c12d779c18cb53ac3968008c64f5b96c2a
+DIST mkdocstrings-python-1.10.2.gh.tar.gz 157534 BLAKE2B 81d0585298008e5065d6896c773394194bd54494723ae2f195a420976879a6d47e443eb099aedf72551e43b88f85e0d13ae11de09a5837aae8a5de4ce69bf119 SHA512 16a0a94793bce9e6471e0778df99ff1249e7a2342d811750504b9654d20392a892a6073f151a09a15ef671f84f24e0bc8fcc0710bf4b82d38d9ae75c1289b001
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.10.2.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.10.2.ebuild
new file mode 100644
index 000000000000..ebaa96b08803
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.10.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.44[${PYTHON_USEDEP}]
+ >=dev-python/mkdocstrings-0.25.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}