summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2016-10-15 14:57:21 -0700
committerDavid Seifert <soap@gentoo.org>2016-10-16 19:24:08 +0200
commitde3a6c813769b869ffabbb095d62cd65d890f2aa (patch)
tree1150eb74fa7f6d7fa7face1792fd3e023bc2a83e
parentnet-irc/hexchat: fix libgdiplus.so & Werror errors (diff)
downloadgentoo-de3a6c81.tar.gz
gentoo-de3a6c81.tar.bz2
gentoo-de3a6c81.zip
net-irc/hexchat: Remove outdated ebuilds
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2563 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-irc/hexchat/hexchat-2.10.2-r1.ebuild174
-rw-r--r--net-irc/hexchat/hexchat-2.12.2.ebuild139
2 files changed, 0 insertions, 313 deletions
diff --git a/net-irc/hexchat/hexchat-2.10.2-r1.ebuild b/net-irc/hexchat/hexchat-2.10.2-r1.ebuild
deleted file mode 100644
index 6d16041239fa..000000000000
--- a/net-irc/hexchat/hexchat-2.10.2-r1.ebuild
+++ /dev/null
@@ -1,174 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-inherit eutils fdo-mime gnome2-utils mono-env multilib python-single-r1
-
-DESCRIPTION="Graphical IRC client based on XChat"
-HOMEPAGE="http://hexchat.github.io/"
-SRC_URI="https://dl.hexchat.net/hexchat/${P}.tar.xz"
-
-LICENSE="GPL-2 plugin-fishlim? ( MIT )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
-IUSE="dbus +gtk ipv6 libcanberra libnotify libproxy libressl nls ntlm perl +plugins plugin-checksum plugin-doat plugin-fishlim plugin-sysinfo python spell ssl theme-manager"
-REQUIRED_USE="plugins? ( python? ( ${PYTHON_REQUIRED_USE} ) )"
-
-DEPEND="dev-libs/glib:2
- dbus? ( >=dev-libs/dbus-glib-0.98 )
- gtk? ( x11-libs/gtk+:2 )
- libcanberra? ( media-libs/libcanberra )
- libproxy? ( net-libs/libproxy )
- libnotify? ( x11-libs/libnotify )
- nls? ( virtual/libintl )
- ntlm? ( net-libs/libntlm )
- plugins? (
- perl? ( >=dev-lang/perl-5.8.0 )
- plugin-sysinfo? ( sys-apps/pciutils )
- python? ( ${PYTHON_DEPS} )
- )
- spell? ( app-text/iso-codes )
- ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )
- theme-manager? ( dev-lang/mono )"
-RDEPEND="${DEPEND}
- spell? ( app-text/enchant )"
-DEPEND="${DEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- nls? ( dev-util/intltool )
- theme-manager? ( dev-util/monodevelop )"
-
-pkg_setup() {
- use plugins && use python && python-single-r1_pkg_setup
- if use theme-manager ; then
- mono-env_pkg_setup
- export XDG_CACHE_HOME="${T}/.cache"
- fi
-
- if use !plugins ; then
- local myplugins
-
- use perl && myplugins+="perl\n"
- use python && myplugins+="python\n"
- use plugin-checksum && myplugins+="plugin-checksum\n"
- use plugin-doat && myplugins+="plugin-doat\n"
- use plugin-fishlim && myplugins+="plugin-fishlim\n"
- use plugin-sysinfo && myplugins+="plugin-sysinfo\n"
-
- if [[ ${myplugins} ]] ; then
- ewarn "The following plugins/interfaces have been disabled, because"
- ewarn "\"plugins\" USE flag is disabled. Check metadata.xml"
- ewarn "to get more information or run \"equery u hexchat\"."
- ewarn "\n${myplugins}"
- fi
- fi
-}
-
-src_prepare() {
- epatch_user
-}
-
-src_configure() {
- econf \
- $(use_enable nls) \
- $(use_enable libproxy socks) \
- $(use_enable ipv6) \
- $(use_enable ssl openssl) \
- $(use_enable gtk gtkfe) \
- $(use_enable !gtk textfe) \
- $(usex plugins \
- "$(usex python "--enable-python=${EPYTHON}" "--disable-python")" \
- "--disable-python" \
- ) \
- $(usex plugins \
- "$(use_enable perl)" \
- "--disable-perl" \
- ) \
- $(use_enable plugins plugin) \
- $(usex plugins \
- "$(use_enable plugin-checksum checksum)" \
- "--disable-checksum" \
- ) \
- $(usex plugins \
- "$(use_enable plugin-doat doat)" \
- "--disable-doat" \
- ) \
- $(usex plugins \
- "$(use_enable plugin-fishlim fishlim)" \
- "--disable-fishlim" \
- ) \
- $(usex plugins \
- "$(use_enable plugin-sysinfo sysinfo)" \
- "--disable-sysinfo" \
- ) \
- $(use_enable dbus) \
- $(use_enable libnotify) \
- $(use_enable libcanberra) \
- $(use_enable ntlm) \
- $(use_enable libproxy) \
- $(use_enable spell isocodes) \
- --enable-minimal-flags \
- $(use_with theme-manager)
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- UPDATE_ICON_CACHE=true \
- UPDATE_MIME_DATABASE=true \
- UPDATE_DESKTOP_DATABASE=true \
- install
- dodoc readme.md
- prune_libtool_files --all
-}
-
-pkg_preinst() {
- if use gtk ; then
- gnome2_icon_savelist
- fi
-}
-
-pkg_postinst() {
- if use gtk ; then
- gnome2_icon_cache_update
- einfo
- else
- einfo
- elog "You have disabled the gtk USE flag. This means you don't have"
- elog "the GTK-GUI for HexChat but only a text interface called \"hexchat-text\"."
- elog
- fi
-
- if use theme-manager ; then
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- elog "Themes are available at:"
- elog " http://hexchat.org/themes.html"
- elog
- fi
-
- einfo
- elog "optional dependencies:"
- elog " media-sound/sox (sound playback if you don't have libcanberra"
- elog " enabled)"
- elog " x11-plugins/hexchat-javascript (javascript support)"
- elog " x11-themes/sound-theme-freedesktop (default BEEP sound,"
- elog " needs libcanberra enabled)"
- einfo
-}
-
-pkg_postrm() {
- if use gtk ; then
- gnome2_icon_cache_update
- fi
-
- if use theme-manager ; then
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- fi
-}
diff --git a/net-irc/hexchat/hexchat-2.12.2.ebuild b/net-irc/hexchat/hexchat-2.12.2.ebuild
deleted file mode 100644
index 530b1572184d..000000000000
--- a/net-irc/hexchat/hexchat-2.12.2.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-inherit autotools fdo-mime gnome2-utils mono-env python-single-r1
-
-DESCRIPTION="Graphical IRC client based on XChat"
-HOMEPAGE="https://hexchat.github.io/"
-
-if [[ "${PV}" == "9999" ]] ; then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="git://github.com/hexchat/hexchat.git"
-else
- SRC_URI="https://dl.hexchat.net/hexchat/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
-fi
-
-LICENSE="GPL-2 plugin-fishlim? ( MIT )"
-SLOT="0"
-IUSE="dbus debug +gtk libcanberra libnotify libproxy libressl lua nls perl plugin-checksum plugin-doat plugin-fishlim plugin-sysinfo python spell ssl theme-manager"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="dev-libs/glib:2
- dbus? ( sys-apps/dbus )
- gtk? ( x11-libs/gtk+:2 )
- libcanberra? ( media-libs/libcanberra )
- libproxy? ( net-libs/libproxy )
- libnotify? ( x11-libs/libnotify )
- lua? ( dev-lang/lua:= )
- nls? ( virtual/libintl )
- perl? ( dev-lang/perl )
- plugin-sysinfo? ( sys-apps/pciutils )
- python? ( ${PYTHON_DEPS} )
- spell? ( app-text/iso-codes )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- theme-manager? ( dev-lang/mono )"
-RDEPEND="${COMMON_DEPEND}
- spell? ( app-text/enchant )"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- dev-util/intltool
- theme-manager? ( dev-util/monodevelop )"
-
-src_prepare() {
- if [[ ${PV} == "9999" ]]; then
- eautoreconf
- fi
- default
-}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- if use theme-manager ; then
- mono-env_pkg_setup
- export XDG_CACHE_HOME="${T}/.cache"
- fi
-}
-
-src_configure() {
- econf \
- --enable-plugin \
- $(use_enable nls) \
- $(use_enable ssl openssl) \
- $(use_enable gtk gtkfe) \
- $(use_enable !gtk textfe) \
- $(use_enable python python "${EPYTHON}") \
- $(use_enable perl) \
- $(use_enable plugin-checksum checksum) \
- $(use_enable plugin-doat doat) \
- $(use_enable plugin-fishlim fishlim) \
- $(use_enable plugin-sysinfo sysinfo) \
- $(use_enable dbus) \
- $(use_enable lua) \
- $(use_enable libnotify) \
- $(use_enable libcanberra) \
- $(use_enable libproxy) \
- $(use_enable spell isocodes) \
- $(use_enable debug) \
- $(use_with theme-manager)
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- UPDATE_ICON_CACHE=true \
- UPDATE_MIME_DATABASE=true \
- UPDATE_DESKTOP_DATABASE=true \
- install
- dodoc readme.md
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_preinst() {
- if use gtk ; then
- gnome2_icon_savelist
- fi
-}
-
-pkg_postinst() {
- if use gtk ; then
- gnome2_icon_cache_update
- else
- elog "You have disabled the gtk USE flag. This means you don't have"
- elog "the GTK-GUI for HexChat but only a text interface called \"hexchat-text\"."
- fi
-
- if use theme-manager ; then
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- elog "Themes are available at:"
- elog " https://hexchat.github.io/themes.html"
- fi
-
- elog
- elog "optional dependencies:"
- elog " media-sound/sox (sound playback if you don't have libcanberra"
- elog " enabled)"
- elog " x11-plugins/hexchat-javascript (javascript support)"
- elog " x11-themes/sound-theme-freedesktop (default BEEP sound,"
- elog " needs libcanberra enabled)"
-}
-
-pkg_postrm() {
- if use gtk ; then
- gnome2_icon_cache_update
- fi
-
- if use theme-manager ; then
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- fi
-}