summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 11:37:01 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 11:37:19 +0200
commitde3d3e2835ef4f1858f8448f9e87b08f2a15525e (patch)
tree91c485dc2e8e277d899e5b47ea4d6a8405c99124
parentperl-module.eclass: extend DIST_TEST="do" to cover make-based tests (diff)
downloadgentoo-de3d3e2835ef4f1858f8448f9e87b08f2a15525e.tar.gz
gentoo-de3d3e2835ef4f1858f8448f9e87b08f2a15525e.tar.bz2
gentoo-de3d3e2835ef4f1858f8448f9e87b08f2a15525e.zip
dev-python/xlsxwriter: Bump to 3.1.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xlsxwriter/Manifest1
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-3.1.8.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/Manifest b/dev-python/xlsxwriter/Manifest
index 9cca20533dbc..785b7de59981 100644
--- a/dev-python/xlsxwriter/Manifest
+++ b/dev-python/xlsxwriter/Manifest
@@ -1 +1,2 @@
DIST XlsxWriter-RELEASE_3.1.7.gh.tar.gz 37369556 BLAKE2B e7eefd4fac6a791f917e19fd5559ac1fef436a0b304a1db9d436e21a2fc412b73de94a2a05a81acec5e297a07a11bdc953774947ec196fe666beb2ce85a2a21a SHA512 fd144eebbcb04e914aff1c2980353f0ddb88ef7841c70d1681561c86d925a201000931dba18bc15965fdb195bf3b2ea959b7c1ba21be8d1c7c6ed678c90c0fc7
+DIST XlsxWriter-RELEASE_3.1.8.gh.tar.gz 37375781 BLAKE2B 152546520391e3900cf00482b9008acc59051dc1a3c459f0d520d30101eeff3e8c999138738cc3fdfb054688f181f8326aae09642d01537f6383f14c34e55c6d SHA512 5d9c101d488d35ec57848bc9c96f397090340f039fb0b291dadb547fe933fecb3e7975d9ebf5b22f1dc4c0276c1357fa381db45bc2e77c223c71483c1db2a66a
diff --git a/dev-python/xlsxwriter/xlsxwriter-3.1.8.ebuild b/dev-python/xlsxwriter/xlsxwriter-3.1.8.ebuild
new file mode 100644
index 000000000000..1298cbbe9cd5
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-3.1.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+TAG=RELEASE_${PV}
+MY_P=XlsxWriter-${TAG}
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="
+ https://github.com/jmcnamara/XlsxWriter/
+ https://pypi.org/project/XlsxWriter/
+"
+SRC_URI="
+ https://github.com/jmcnamara/XlsxWriter/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}