summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-07-03 17:44:22 +0200
committerUlrich Müller <ulm@gentoo.org>2021-07-04 16:01:51 +0200
commitde46daff9a9db4b73a5fd8125f86e7cd2a318843 (patch)
tree8570b4e8572019ad927a5f2853684a0aad705313
parentdev-vcs/git: Update from l10n.eclass to plocale.eclass (diff)
downloadgentoo-de46daff9a9db4b73a5fd8125f86e7cd2a318843.tar.gz
gentoo-de46daff9a9db4b73a5fd8125f86e7cd2a318843.tar.bz2
gentoo-de46daff9a9db4b73a5fd8125f86e7cd2a318843.zip
games-emulation/dolphin: Update from l10n.eclass to plocale.eclass
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20210506.ebuild8
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild b/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild
index fd44c78fa9e2..5a9c3f739250 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PLOCALES="ar ca cs da de el en es fa fr hr hu it ja ko ms nb nl pl pt pt_BR ro ru sr sv tr zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit cmake desktop xdg-utils l10n pax-utils
+inherit cmake desktop xdg-utils pax-utils plocale
if [[ ${PV} == *9999 ]]
then
@@ -123,15 +123,15 @@ src_prepare() {
remove_locale() {
# Ensure preservation of the backup locale when no valid LINGUA is set
- if [[ "${PLOCALE_BACKUP}" == "${1}" ]] && [[ "${PLOCALE_BACKUP}" == "$(l10n_get_locales)" ]]; then
+ if [[ "${PLOCALE_BACKUP}" == "${1}" ]] && [[ "${PLOCALE_BACKUP}" == "$(plocale_get_locales)" ]]; then
return
else
rm "Languages/po/${1}.po" || die
fi
}
- l10n_find_plocales_changes "Languages/po/" "" '.po'
- l10n_for_each_disabled_locale_do remove_locale
+ plocale_find_changes "Languages/po/" "" '.po'
+ plocale_for_each_disabled_locale remove_locale
# About 50% compile-time speedup
use vulkan || sed -i -e '/Externals\/glslang/d' CMakeLists.txt
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index b8b8e1e3b4e3..b2fd4d445542 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PLOCALES="ar ca cs da de el en es fa fr hr hu it ja ko ms nb nl pl pt pt_BR ro ru sr sv tr zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit cmake desktop xdg-utils l10n pax-utils
+inherit cmake desktop xdg-utils pax-utils plocale
if [[ ${PV} == *9999 ]]
then
@@ -122,15 +122,15 @@ src_prepare() {
remove_locale() {
# Ensure preservation of the backup locale when no valid LINGUA is set
- if [[ "${PLOCALE_BACKUP}" == "${1}" ]] && [[ "${PLOCALE_BACKUP}" == "$(l10n_get_locales)" ]]; then
+ if [[ "${PLOCALE_BACKUP}" == "${1}" ]] && [[ "${PLOCALE_BACKUP}" == "$(plocale_get_locales)" ]]; then
return
else
rm "Languages/po/${1}.po" || die
fi
}
- l10n_find_plocales_changes "Languages/po/" "" '.po'
- l10n_for_each_disabled_locale_do remove_locale
+ plocale_find_changes "Languages/po/" "" '.po'
+ plocale_for_each_disabled_locale remove_locale
# About 50% compile-time speedup
use vulkan || sed -i -e '/Externals\/glslang/d' CMakeLists.txt