summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2018-04-02 10:39:00 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2018-04-02 10:39:00 +0200
commitde4acfb4deb272a2dbd1088cc23e38679915bb4d (patch)
tree9127ab96b7f7fb61def4bb9edee243538937884b
parentmedia-libs/lensfun: arm stable, bug #647060 (diff)
downloadgentoo-de4acfb4.tar.gz
gentoo-de4acfb4.tar.bz2
gentoo-de4acfb4.zip
media-libs/hamlib: Version bump
Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--media-libs/hamlib/Manifest1
-rw-r--r--media-libs/hamlib/hamlib-3.2.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index fa6f074d6723..9a564d4b9c04 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -1 +1,2 @@
DIST hamlib-3.1.tar.gz 2130615 BLAKE2B dbc348d5df04015e1706b6f165496f0b0d9a4f7ce5e5ba6c8589349c1c9c1119ef31e8c3d4ba14666d19f3638bf27ad9b4a566af2fd4054faafc0604b8aeafd0 SHA512 befc5c407379e30711bde2affb9c191add6dbb04a36c1309f8771170cf04156c48609a094775638036282e085de6c78d09ef8d2760d69c595471e16e985e0885
+DIST hamlib-3.2.tar.gz 2223125 BLAKE2B c9bffa2b4d2aa4b3f9c590276058c159aa1236f22d3f37a063124af09002dc3034a88fd6f1273b5f4562ae22618222ea50c254fb59384bfae778448fe029ef49 SHA512 9aec2d361980abafdedf7b80f5b8bcf5b71f4f0c32bbfecebc0a50e6f74eb263ddc5188cf77283ed7361baabedb8364a2ce94a12fdda1bbdfaa0a030f510f224
diff --git a/media-libs/hamlib/hamlib-3.2.ebuild b/media-libs/hamlib/hamlib-3.2.ebuild
new file mode 100644
index 000000000000..eac2786bab63
--- /dev/null
+++ b/media-libs/hamlib/hamlib-3.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit autotools-utils eutils multilib python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="https://www.hamlib.org"
+SRC_URI="https://www.github.com/${PN}/${PN}/releases/download/${PVR}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0=
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND=" ${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/swig
+ >=sys-devel/libtool-2.2
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer TODO)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # fix hardcoded libdir paths
+ sed -i -e "s#fix}/lib#fix}/$(get_libdir)/hamlib#" \
+ -e "s#fix}/include#fix}/include/hamlib#" \
+ hamlib.pc.in || die "sed failed"
+
+ # Correct install target to whatever INSTALLDIRS says and use vendor
+ # installdirs everywhere (bug #611550)
+ sed -i -e "s#install_site#install#" \
+ -e 's#MAKEFILE="Hamlib-pl.mk"#MAKEFILE="Hamlib-pl.mk" INSTALLDIRS=vendor#' \
+ bindings/Makefile.am || die "sed failed patching for perl"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --libdir=/usr/$(get_libdir)/hamlib
+ --disable-static
+ --with-xml-support
+ $(use_with perl perl-binding)
+ $(use_with python python-binding)
+ $(use_with tcl tcl-binding)
+ --disable-silent-rules
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/html/")
+ autotools-utils_src_install
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins "${AUTOTOOLS_BUILD_DIR}"/hamlib.pc || die "doins failed"
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib || die "doenvd failed"
+}