summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-14 22:48:27 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-14 22:51:21 -0500
commitde5ed6b1f82c2f48f3bcafb2a81c5d820f857f76 (patch)
tree122b805f9e39defd05776c025f2d227ea38b8d74
parentdev-haskell/dbus: Bump to 1.2.27, patch to allow earlier TH (diff)
downloadgentoo-de5ed6b1.tar.gz
gentoo-de5ed6b1.tar.bz2
gentoo-de5ed6b1.zip
x11-terms/kitty: update live (now uses go)
Build system does not let this be optional at the moment. Just a quickfix for now given was barely added, will review handling this when there is release. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index b22f36ef47df..40981a3c7d82 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
-inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+inherit edo go-module optfeature multiprocessing python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -66,6 +66,15 @@ BDEPEND="
wayland? ( dev-util/wayland-scanner )"
[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
src_prepare() {
default