summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-02 05:22:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-02 05:22:44 +0100
commitde731d9b8d2eaa57b896d0a089a9ad02ce1576dd (patch)
treed68a3061df1cbba8235b56950e28a28b5c13576f
parentdev-python/botocore: Bump to 1.29.82 (diff)
downloadgentoo-de731d9b.tar.gz
gentoo-de731d9b.tar.bz2
gentoo-de731d9b.zip
dev-python/boto3: Bump to 1.26.82
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.82.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 5bfc5322a756..78f40df0f997 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.26.74.gh.tar.gz 602525 BLAKE2B 6d9b397864649ecd9b3f46bcee832c57cdce
DIST boto3-1.26.79.gh.tar.gz 605312 BLAKE2B c36b86ab289be9c08a1ab43274a4f4db71cede08598b6f8092af8404bc9994e345b263b144ee3a1974ea276fce63c330d7ffa6335bb889bea32e380e9003a8c7 SHA512 cfc789296b904c0c3bd3999153067f4fb174b323f0fbd22e8f4a49aed98338e20fd238876e2f55f608f5d6b60b584e15d370400e8d0a8a00b0689e0867d00f05
DIST boto3-1.26.80.gh.tar.gz 606204 BLAKE2B ae80c1ec7e99f48844c4eec39df1f6802df1fbbf2d94f1b7ddc04c7a21cb885823ebadb11cf9e81b51af9aa5f09775c02e52e926b94c49331307873b86702446 SHA512 e4ab89f2afe506d7d1ba9e1615e3a92ba4bf5dc9a85d3a14f034c1b14733d99cebf594bb6dc80914bf444da34d09c045c8933cf3c97e6ccfa9e31901e99d76ee
DIST boto3-1.26.81.gh.tar.gz 611431 BLAKE2B e3f607e4bbd4ae7002168a697c6c3081b3713acbf7d7c8abdb1016b63f9ac5b16ae44255f707272db6a7b4c657210af0ed1c355889b01434683889b28de9d4e7 SHA512 30faa2d60f5f661e4d56a57c5b9d258ad3de260be2a21723b921f2383e290ca0b3d417a4a970ba3defd8f8196deaade2741117393c664b5fe267deab2e210e06
+DIST boto3-1.26.82.gh.tar.gz 611850 BLAKE2B fbf4581d616c6978482689e42a5cf8dc846ef91c77bd9f94298bed1ec50cdf41bc999ee81a1dd43b697da282f2774133daf6c6789d7d78b78aeb272c42f91f56 SHA512 8dc96da11d6da19610810c850c69070d25629e583f4eda822c218f4ad09295d25d3ae689a321c6a0c5f0c27e34717c44eb708950b4f37fe1d27f1f48205e5870
diff --git a/dev-python/boto3/boto3-1.26.82.ebuild b/dev-python/boto3/boto3-1.26.82.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.82.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}