summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2021-07-04 11:41:12 +1000
committerSam Jorna <wraeth@gentoo.org>2021-07-04 11:53:06 +1000
commitde881ba73aef70b94b1dc43a78ff69bd8376aec2 (patch)
tree69c3073ffd6cfd9ffb7959ca9a36e567c6b776ce
parentsys-kernel/gentoo-kernel-bin: bump to 5.12.13 for arm64 (diff)
downloadgentoo-de881ba73aef70b94b1dc43a78ff69bd8376aec2.tar.gz
gentoo-de881ba73aef70b94b1dc43a78ff69bd8376aec2.tar.bz2
gentoo-de881ba73aef70b94b1dc43a78ff69bd8376aec2.zip
net-irc/limnoria-plugins-chantracker: bump to 1.6
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
-rw-r--r--net-irc/limnoria-plugins-chantracker/Manifest1
-rw-r--r--net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-chantracker/Manifest b/net-irc/limnoria-plugins-chantracker/Manifest
index 773fe5b9a4f6..054f3bb1b5f3 100644
--- a/net-irc/limnoria-plugins-chantracker/Manifest
+++ b/net-irc/limnoria-plugins-chantracker/Manifest
@@ -1,2 +1,3 @@
DIST limnoria-plugins-chantracker-1.5_p20210530.tar.gz 47071 BLAKE2B b38cbe399d6cda9ee9d5e873a50d2f529d91b697c32ed4d74fb8812b8090a42103283878f8874f0a974cfdf1d117e2401935edef678d1d71af338760555a7a92 SHA512 7b5e459d17b28fd00b9306a7acd8c2a36eb668031c24eb05b9c51354e5cf270fb1b388949047c0531d9e8cd62291d8f7ec9bd339d3b3b6c1680dc184c44d3b21
DIST limnoria-plugins-chantracker-1.5_p20210619.tar.gz 47777 BLAKE2B 14e44e025d4044c38504ec9cea31b08d9a442769b5dc3cf6d71b89526ec98a43a31068a5557b3fc257c6254b0f6aab989d148066b79667b17c75f01e741c10ea SHA512 8ef99fbd41929172ae362a656030fda7f4d522eddfd29a3f9e8f9e9a138903faa672c4b872ce76da39d716f3443c159e7c40111cee015230e781bc387c299718
+DIST limnoria-plugins-chantracker-1.6.tar.gz 48050 BLAKE2B aedf93eccbda87eb488b7a0c6e28597198ce37a68a006771b15d6044eea8d7efd9fcf5b178ff4309715534286b74c7ee81e47241ec6406c26d1b17f5bb442d5a SHA512 c7ddd629818edc85d4ebc589d85fa66ef757ac27d0710e4a5512a469892c5c3caad6b98a3ebbce0abc797e0b64bdbd4ad2445e2127c91e266abddec58c3ae859
diff --git a/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6.ebuild b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6.ebuild
new file mode 100644
index 000000000000..27da210ea972
--- /dev/null
+++ b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+DESCRIPTION="supybot ban management and channel flood/spam/repeat protections plugin"
+HOMEPAGE="https://github.com/ncoevoet/ChanTracker"
+SRC_URI="https://github.com/ncoevoet/ChanTracker/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="net-irc/limnoria"
+
+DOCS="README.md"
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/ncoevoet/ChanTracker
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before this plugin can be used, your bot will need to be told where to"
+ elog "load it from. To do this, add /usr/share/limnoria-extra-plugins/ncoevoet when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/ncoevoet"
+}