summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-02-07 15:21:25 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-02-07 15:21:41 +0100
commitde8d5c247b2699a7c713f13557e1cca59915f9b9 (patch)
treeab1dc1d8bd75a8714aee1d618764e912c18f8747
parentapp-admin/terraform: Version bump (v0.14.6) (diff)
downloadgentoo-de8d5c247b2699a7c713f13557e1cca59915f9b9.tar.gz
gentoo-de8d5c247b2699a7c713f13557e1cca59915f9b9.tar.bz2
gentoo-de8d5c247b2699a7c713f13557e1cca59915f9b9.zip
media-sound/qsynth: bump to 0.9.1, xdg-utils -> xdg, updated live
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch21
-rw-r--r--media-sound/qsynth/qsynth-0.9.1.ebuild71
-rw-r--r--media-sound/qsynth/qsynth-9999.ebuild10
4 files changed, 94 insertions, 9 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index b6fb37b4356f..c24bb02be3ea 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1,2 +1,3 @@
DIST qsynth-0.6.3.tar.gz 382990 BLAKE2B 37565c86b077602cd681b92aaea20d4aa07db1c4cf51d391562b5226ddde70dad0a3f641f0fcf54f35c6bb1a9e487a779c22237b0c8087666b7a2c1dea8a511e SHA512 7320a355b5fbb347b04b46fdfe86c13ab18b264cff09f2ed133e2b065febac27e58bd709eea284b4d0f98034059647ad6e9b97638fdd75edb1524fd3cf9f07a2
DIST qsynth-0.9.0.tar.gz 383118 BLAKE2B d9464a2f122d7281ff69171c431fff72d05886ec130d20aae8d8f122e1cefd1180b8bcdc157f324c5cdbc7e2c524c82a9cc7f481efc8b69912ce61912e73ed58 SHA512 5cc0e099cd05f3639ded81642bde80205c8921b65d22dcb32d40ac874107043edeb672e69d7e4734e0fd37a498be2e5b787f0b8c1707be45e39cfab616fd522c
+DIST qsynth-0.9.1.tar.gz 393897 BLAKE2B f63766614d821409cd12e418e36b8dbd739da8e2cd7deae91c2b00dd4f5ba2f447a3ca19c3829de3282e368baa37567333be051641221300d13dd7948d762008 SHA512 70bba332b90963d1c1da18fb3de8f05544fed3406c2144b6ed78cf93720cbcb684ff367d7ef4bc80be94ebea060b38753ae0cb183e85f96f127014c08de701b0
diff --git a/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch b/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch
new file mode 100644
index 000000000000..9ea401abc26e
--- /dev/null
+++ b/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 47ea36f..0194f32 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,6 +8,7 @@ project(qsynth
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+
+ set (CONFIG_VERSION ${PROJECT_VERSION})
++#[[
+ execute_process (
+ COMMAND git describe --tags --dirty --abbrev=6
+ OUTPUT_VARIABLE GIT_DESCRIBE_OUTPUT
+@@ -29,6 +30,8 @@ if (GIT_DESCRIBE_RESULT EQUAL 0)
+ else ()
+ set (VERSION "${PROJECT_VERSION}")
+ endif ()
++]]
++set (VERSION "${PROJECT_VERSION}")
+
+ set (PACKAGE_NAME "Qsynth")
+ set (PACKAGE_VERSION "${VERSION}")
diff --git a/media-sound/qsynth/qsynth-0.9.1.ebuild b/media-sound/qsynth/qsynth-0.9.1.ebuild
new file mode 100644
index 000000000000..dac583b64db9
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.9.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop qmake-utils xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-cmake-no-git-version.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}
diff --git a/media-sound/qsynth/qsynth-9999.ebuild b/media-sound/qsynth/qsynth-9999.ebuild
index b0cfa6dfb05c..f2e790dc5a2b 100644
--- a/media-sound/qsynth/qsynth-9999.ebuild
+++ b/media-sound/qsynth/qsynth-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake desktop qmake-utils xdg-utils
+inherit cmake desktop qmake-utils xdg
DESCRIPTION="Qt application to control FluidSynth"
HOMEPAGE="https://qsynth.sourceforge.io/"
@@ -67,11 +67,3 @@ src_install() {
make_desktop_entry "${cmd}" Qsynth qsynth
}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}