summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-17 13:55:01 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-17 14:03:42 +0100
commitde97c7337d36dd0fa3267cc551f99e76d762c2ba (patch)
treec3c834b32539b4ec514836445f0f96ea98e45b5c
parentmail-mta/protonmail-bridge: add 1.8.10, remove 1.8.{3,7} (diff)
downloadgentoo-de97c733.tar.gz
gentoo-de97c733.tar.bz2
gentoo-de97c733.zip
dev-python/fido2: add 0.9.3
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-0.9.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index 3143d5edae8c..adbd561194f2 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -1,2 +1,3 @@
DIST fido2-0.8.1.tar.gz 201198 BLAKE2B 33411dd05d7f513445afa8a6fc4bb90f3989a655fa05d2ba9da411aa7eea3b30ffa253fae6586f76c416115e5bec90f6f120472a49a0acfbd91020d2cba8f74d SHA512 fc0753ea694f2170d529129764cd9f9c5439cd2f467e4f384d7a698266ee8391a5c9c7c6e51d2dc2a99b93fca1c7d5288d5236e302672a87b8ca7704f328c0b5
DIST fido2-0.9.1.tar.gz 206395 BLAKE2B 9a9b5d0dd808de896c91aa605540a1968aab7ae543336521d4a206f27bcf836c57e88aa6cdd0bacf71db8d16a0f94c2f9c16b16ca415363fd0b5e145a448ec18 SHA512 cde8c247fe0875129a890866ab76d40b2bd6feee86ff1ccb4b9ec5e6dc037e569fc8d969b51a456b5e66c6f7c67e18d14c3917375d5de85bbe7da5af3254f797
+DIST fido2-0.9.3.tar.gz 217894 BLAKE2B ccc3a9b59045216037664b5bf4b969a79b86b300f67fc4253b563acbbee98912ea076996772f17b88141d2a36a933b4926de96f05c53e204d0bb4eaaa2daad6b SHA512 f105c347784cdfab88ab08852227d24f4bca623145f7f76bd066dadab6ada1eae751934fd4dc7436a5c5fb3a0ed2fc4d5c59bb2a93888d470028f0713ca7e09e
diff --git a/dev-python/fido2/fido2-0.9.3.ebuild b/dev-python/fido2/fido2-0.9.3.ebuild
new file mode 100644
index 000000000000..b57545910a73
--- /dev/null
+++ b/dev-python/fido2/fido2-0.9.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="https://github.com/Yubico/python-fido2"
+SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0/0.9" # Bumped every time a backwards-incompatible version is released
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="examples"
+RESTRICT="test" # Tests require <dev-python/mock-4
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Disable tests, <dev-python/mock-4 doesn't exist
+# DEPEND="${DEPEND}
+# test? (
+# ${RDEPEND}
+# <dev-python/mock-4[${PYTHON_USEDEP}]
+# >=dev-python/pyfakefs-3.4[${PYTHON_USEDEP}]
+# )
+# "
+#
+# When tests are available again, remember to add a custom
+# test phase that runs 'python -m unittest discover -v'
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}