summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-03-16 21:25:37 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-19 09:24:55 +0200
commitde98d84f3e38bfaee359cbf6bb9d2e6c4814c52b (patch)
tree1e5de9b723959f040eaeadb6c84f8a6df4b4bb33
parentmail-client/thunderbird: drop 78.8.0 (diff)
downloadgentoo-de98d84f3e38bfaee359cbf6bb9d2e6c4814c52b.tar.gz
gentoo-de98d84f3e38bfaee359cbf6bb9d2e6c4814c52b.tar.bz2
gentoo-de98d84f3e38bfaee359cbf6bb9d2e6c4814c52b.zip
net-misc/unison: Release candidate 2.51.4_rc2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-misc/unison/Manifest1
-rw-r--r--net-misc/unison/unison-2.51.4_rc2.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index 0a56449311a7..148332b235c7 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -4,3 +4,4 @@ DIST unison-2.48.4-manual.pdf 516093 BLAKE2B 8e752a01b8c4335d6687b1f4f20ee09fda9
DIST unison-2.51.3_p20201024.tar.gz 1371551 BLAKE2B 780cc176ed203345408551aaa11990e4da1ec0d4adfd928f3e8ff9c180f35fafb6ac097c00c95da8fe9178db122ea025e9f4336413f0694cea099ab80e2ae00e SHA512 87c7ce33621bc323607e901547da30b8fc0a842ba35128627f5d44fb4befd76ff94586ec1f8eb1f3359da756d09d8bf2481cf0d6eb2ea421113e0e4efdcbdf61
DIST unison-2.51.3_p20201127.tar.gz 1374770 BLAKE2B 83c133f2cb99e10fac96efde333291a671edab5eb45dd6dcf56cb25845385425353a5f413ab752361124ec7bbac21daf3f813d5539b21229d943cf7f0bfae2fd SHA512 4b978a5e3df620317b7a9214054d64f319d09c5617b07ddf3cf76b18c6888841ce791f7b6a4ef70c64b146e3e4f25a5904584fb576703c2de4b17cfcffa8905a
DIST unison-2.51.4_rc1.tar.gz 1374314 BLAKE2B 8b0218fa903ed8f1ceb3b489df8fbda5ba9fddfbe4b9440098d16dd298e15666bfc3722d1735069843511b7b39e8b49463c5b26b940ff770c7fcdfbd63eed1c2 SHA512 7b3fe2d09ff35ccdd68306d8fce6edd947489554c54afebe44d096210d2d8e58c6947386c2795c668070f5ba14a28547cee31d947d54ec90ed63927ad766c0bb
+DIST unison-2.51.4_rc2.tar.gz 1377263 BLAKE2B d403e019f0757f66be5157cff97596c9dae1306a5ba33af27fe55a69fb1ae50d6ef6db54403d14a0afb27cb7a0ebe198021d6cdf58430c530575fc934c837703 SHA512 c61f827490036fbe3074ce5d970e6b4e981a4fde848c307c817f51d73f450d4b5d437503f5392bd2b654121547919b9724112383f71736a9e0e7b308bc3e99b6
diff --git a/net-misc/unison/unison-2.51.4_rc2.ebuild b/net-misc/unison/unison-2.51.4_rc2.ebuild
new file mode 100644
index 000000000000..02f43dee92d9
--- /dev/null
+++ b/net-misc/unison/unison-2.51.4_rc2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="https://www.seas.upenn.edu/~bcpierce/unison/"
+SRC_URI="https://github.com/bcpierce00/unison/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="debug doc gtk +ocamlopt threads"
+RESTRICT="!ocamlopt? ( strip )" # https://bugs.gentoo.org/685776#c0
+
+# ocaml version so we are sure it has ocamlopt use flag
+BDEPEND="dev-lang/ocaml:=[ocamlopt?]
+ doc? ( app-text/dvipsk
+ app-text/ghostscript-gpl
+ dev-texlive/texlive-latex )"
+DEPEND="gtk? ( dev-ml/lablgtk:2= )"
+RDEPEND="gtk? ( dev-ml/lablgtk:2=
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ >=app-eselect/eselect-unison-0.4"
+
+DOCS=( BUGS.txt CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
+
+src_prepare() {
+ # https://github.com/bcpierce00/unison/issues/416
+ sed -e "/ifdef\ HEVEA/,/endif/d" -i doc/Makefile || die
+ # https://github.com/bcpierce00/unison/pull/415
+ sed -e "/myName/d" -i doc/docs.ml || die
+ default
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf+=( THREADS=true )
+ fi
+
+ if use debug; then
+ myconf+=( DEBUGGING=true )
+ fi
+
+ if use gtk; then
+ myconf+=( UISTYLE=gtk2 )
+ else
+ myconf+=( UISTYLE=text )
+ fi
+
+ use ocamlopt || myconf+=( NATIVE=false )
+
+ if use doc; then
+ VARTEXFONTS="${T}/fonts" emake $myconf CFLAGS="" HEVEA=false docs
+ fi
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS="" src
+}
+
+src_test() {
+ emake test CFLAGS=""
+}
+
+src_install() {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ local binname
+ cd src || die
+ for binname in unison unison-fsmonitor; do
+ newbin ${binname} ${binname}-${SLOT}
+ done
+
+ if use gtk; then
+ newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
+ make_desktop_entry ${PN}-${SLOT} "${PN} (${SLOT})" "${PN}-${SLOT}"
+ fi
+
+ # Waiting for https://github.com/bcpierce00/unison/issues/411
+ if use doc; then
+ DOCS+=( ../doc/unison-manual.pdf )
+ # HTML_DOCS=( "${DISTDIR}/${P}-manual.html" )
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+ eselect unison update || die
+
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}