summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-08-27 01:11:34 +0200
committerLouis Sautier <sbraz@gentoo.org>2019-08-27 01:12:50 +0200
commitdead0ce4020de9e4d2cc394b122f2ac03346010b (patch)
tree3e635f18b3bab5e908e96f5aaa117c26bacf6cc7
parentdev-python/zipp: remove old (diff)
downloadgentoo-dead0ce4.tar.gz
gentoo-dead0ce4.tar.bz2
gentoo-dead0ce4.zip
app-text/wgetpaste: backport upstream's patch to fix bpaste.net
Package-Manager: Portage-2.3.71, Repoman-2.3.16 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--app-text/wgetpaste/files/wgetpaste-2.29-fix-bpaste.patch40
-rw-r--r--app-text/wgetpaste/wgetpaste-2.29-r1.ebuild29
2 files changed, 69 insertions, 0 deletions
diff --git a/app-text/wgetpaste/files/wgetpaste-2.29-fix-bpaste.patch b/app-text/wgetpaste/files/wgetpaste-2.29-fix-bpaste.patch
new file mode 100644
index 000000000000..0af9a6f855d7
--- /dev/null
+++ b/app-text/wgetpaste/files/wgetpaste-2.29-fix-bpaste.patch
@@ -0,0 +1,40 @@
+From 6175f89cb618fef83882ed86ab049a7fd1035770 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bo=20=C3=98rsted=20Andresen?= <zlin@exherbo.org>
+Date: Tue, 23 Jul 2019 00:16:19 +0200
+Subject: [PATCH] Fix handling of bpaste urls.
+
+---
+ wgetpaste | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/wgetpaste b/wgetpaste
+index 585fcd9..99eb7f1 100755
+--- a/wgetpaste
++++ b/wgetpaste
+@@ -181,7 +181,8 @@ xml+cheetah xml+django xml+evoque xml+lasso xml+mako xml+myghty xml+php xml+erb
+ xml+velocity xml xquery xslt xtend yaml"
+ EXPIRATIONS_pinnwand="1day 1week 1month never"
+ POST_pinnwand="submit=Paste! % % lexer expiry % code"
+-REGEX_RAW_pinnwand='s|^\(https\?://[^/]*/\)show\(/[[:alnum:]]*/\?\)$|\1raw\2|'
++REGEX_LOC_pinnwand="\(/show/[^ ]*\).*$|https://bpaste.net\1"
++REGEX_RAW_pinnwand='s|^\(https\?://[^/]*/\)show\(/[^ ]*/\?\)$|\1raw\2|'
+
+ ### errors
+ die() {
+@@ -550,11 +551,15 @@ postdata() {
+
+ # get url from response from server
+ geturl() {
+- local regex
++ local regex location
+ regex=REGEX_URL_$ENGINE
++ location=REGEX_LOC_$ENGINE
+ if [[ -n ${!regex} ]]; then
+ [[ needstdout = $1 ]] && return 0
+ sed -n -e "${!regex}" <<< "$*"
++ elif [[ -n ${!location} ]]; then
++ [[ needstdout = $1 ]] && return 1
++ sed -n -e "s|^.*Location: ${!location}|p" <<< "$*"
+ else
+ [[ needstdout = $1 ]] && return 1
+ sed -n -e 's|^.*Location: \(https\{0,1\}://[^ ]*\).*$|\1|p' <<< "$*"
diff --git a/app-text/wgetpaste/wgetpaste-2.29-r1.ebuild b/app-text/wgetpaste/wgetpaste-2.29-r1.ebuild
new file mode 100644
index 000000000000..175617a320c6
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.29-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="http://wgetpaste.zlin.dk/"
+SRC_URI="http://wgetpaste.zlin.dk/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="+ssl"
+
+DEPEND=""
+RDEPEND="net-misc/wget[ssl?]"
+
+PATCHES=( "${FILESDIR}/${P}-fix-bpaste.patch" )
+
+src_prepare() {
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+ default
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}