summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-11-20 22:37:25 +0000
committerMarek Szuba <marecki@gentoo.org>2022-11-20 22:37:25 +0000
commitdeaebae2424f8d8d0ba85d7f2257de3f801a8aa4 (patch)
treedc2d502ecbeb35e21e19a8edfb3f33c49875b002
parentdev-python/click-help-colors: stabilize 0.9.1 for ALLARCHES (diff)
downloadgentoo-deaebae2424f8d8d0ba85d7f2257de3f801a8aa4.tar.gz
gentoo-deaebae2424f8d8d0ba85d7f2257de3f801a8aa4.tar.bz2
gentoo-deaebae2424f8d8d0ba85d7f2257de3f801a8aa4.zip
dev-python/click-help-colors: switch to PEP-517 mode
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/click-help-colors/Manifest1
-rw-r--r--dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/click-help-colors/Manifest b/dev-python/click-help-colors/Manifest
index 6aae08de5ed1..ef6c4e89c545 100644
--- a/dev-python/click-help-colors/Manifest
+++ b/dev-python/click-help-colors/Manifest
@@ -1 +1,2 @@
+DIST click-help-colors-0.9.1.gh.tar.gz 101042 BLAKE2B 0f40d6d15f8e0a4647212f57e071c49b66bcd2b3d7ef582bd7d8a14135e50028f3ceb07987b5b74a868d998c12886a711f40e1d85b541566c63dca39e43a907d SHA512 ac4ce56ab249f7b98f670a6624700109f20a7c666e006b891d5c9fd4977512a0c94d82f6b43915952179abc946899f85fa1d358cd3d59508ef341ba22d8fc745
DIST click-help-colors-0.9.1.tar.gz 101042 BLAKE2B 0f40d6d15f8e0a4647212f57e071c49b66bcd2b3d7ef582bd7d8a14135e50028f3ceb07987b5b74a868d998c12886a711f40e1d85b541566c63dca39e43a907d SHA512 ac4ce56ab249f7b98f670a6624700109f20a7c666e006b891d5c9fd4977512a0c94d82f6b43915952179abc946899f85fa1d358cd3d59508ef341ba22d8fc745
diff --git a/dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild b/dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..485d4219691e
--- /dev/null
+++ b/dev-python/click-help-colors/click-help-colors-0.9.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorization of help messages in Click"
+HOMEPAGE="https://github.com/click-contrib/click-help-colors"
+SRC_URI="
+ https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="examples"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}