summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-25 18:32:24 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-27 15:28:48 -0800
commitdeb0b397039d0f36e8330ba708497953d2944686 (patch)
treec2f1eb56a642071e32551e05fc9ec9219658293a
parentdev-python/psutil: version bump. (diff)
downloadgentoo-deb0b397.tar.gz
gentoo-deb0b397.tar.bz2
gentoo-deb0b397.zip
dev-python/reflink: new package
pythonic wrapper around reflink family of syscalls Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-python/reflink/Manifest1
-rw-r--r--dev-python/reflink/metadata.xml15
-rw-r--r--dev-python/reflink/reflink-0.2.1.ebuild44
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/reflink/Manifest b/dev-python/reflink/Manifest
new file mode 100644
index 000000000000..962a554aedba
--- /dev/null
+++ b/dev-python/reflink/Manifest
@@ -0,0 +1 @@
+DIST reflink-0.2.1.tar.gz 14638 BLAKE2B a6449ebb27619ead9ff8452df6c48f3617e5f06eb347fbbe14ab00b9a43c01de8e101466288ac6fb73602165d4d4e9315f941c2f28dffe245ed2c39a10a61cf1 SHA512 5995ed787bda93cb46d99a603110768087420edd72c01d5f3f7f08a3f8f63b4629b900a3c173dd7f3119a892ac19ab1a9c3000ddd83810b22a52dfb5fb892a28
diff --git a/dev-python/reflink/metadata.xml b/dev-python/reflink/metadata.xml
new file mode 100644
index 000000000000..e3b3aabe2dda
--- /dev/null
+++ b/dev-python/reflink/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python wrapper around the reflink system calls.
+ Btrfs, XFS, OCFS2 reflink support, Apple macOS APFS clonefile support.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">reflink</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/reflink/reflink-0.2.1.ebuild b/dev-python/reflink/reflink-0.2.1.ebuild
new file mode 100644
index 000000000000..8c8c593ccf52
--- /dev/null
+++ b/dev-python/reflink/reflink-0.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://gitlab.com/rubdos/pyreflink"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ sys-fs/btrfs-progs
+ )
+"
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# goes places, like writing to /dev or creating btrfs volumes
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}