summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-12 10:09:36 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-12 10:09:36 +0200
commitdeb1209ee78bd56af26bd3af2020566ce402cd3c (patch)
treed463b7f946e16ccce4c5546eea779f73c09152bf
parentdev-libs/elfio: Remove last-rited pkg (diff)
downloadgentoo-deb1209e.tar.gz
gentoo-deb1209e.tar.bz2
gentoo-deb1209e.zip
dev-libs/fampp2: Remove last-rited pkg
Closes: https://bugs.gentoo.org/694170 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/fampp2/Manifest1
-rw-r--r--dev-libs/fampp2/fampp2-7.0.1-r3.ebuild59
-rw-r--r--dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch78
-rw-r--r--dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch67
-rw-r--r--dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch46
-rw-r--r--dev-libs/fampp2/metadata.xml8
-rw-r--r--profiles/package.mask5
7 files changed, 0 insertions, 264 deletions
diff --git a/dev-libs/fampp2/Manifest b/dev-libs/fampp2/Manifest
deleted file mode 100644
index 0fad63530ee5..000000000000
--- a/dev-libs/fampp2/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST fampp2-7.0.1.tar.bz2 288073 BLAKE2B f74659c83af82eeed6c5f711a9273f2d8c7704f04c8407992bee7478d2ef20b6d2ecf37c5d292be35c126474052341c49f8a0d30d056c24e2404b17d0123dfd7 SHA512 317a5cfd383418265cafea0840af8b7c714a04b34265ebfba73230ff2492df8f7884797529916693ab489bdbc94799ca83e015cf0bcfffaea6b28b3a7f9ccbd0
diff --git a/dev-libs/fampp2/fampp2-7.0.1-r3.ebuild b/dev-libs/fampp2/fampp2-7.0.1-r3.ebuild
deleted file mode 100644
index 7854cb30ecee..000000000000
--- a/dev-libs/fampp2/fampp2-7.0.1-r3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="C++ wrapper for fam"
-HOMEPAGE="https://sourceforge.net/projects/fampp/"
-SRC_URI="mirror://sourceforge/fampp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- >=dev-libs/ferrisloki-2.0.3
- dev-libs/glib:2
- >=dev-libs/libsigc++-2.6:2
- virtual/fam
- x11-libs/gtk+:2"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- # Fix compat with libsigc++-2.6, #569700
- "${FILESDIR}/${PN}-7.0.1-libsigc++-2.6.patch"
- # Fix completely broken buildsystem
- "${FILESDIR}/${PN}-7.0.1-fix-buildsystem.patch"
- # Fix noexcept(true) for dtors in >=C++11 with GCC 6, #595308
- "${FILESDIR}/${PN}-7.0.1-fix-gcc6.patch"
-)
-
-src_prepare() {
- default
- mv configure.{in,ac} || die
- eautoreconf
-}
-
-src_configure() {
- # libsigc++-2.6 requires building with C++11
- append-cxxflags -std=c++11
-
- # glib and gtk+ are only required for some examples
- econf \
- --disable-static \
- --disable-glibtest \
- --disable-gtktest \
- --disable-stlport \
- $(use_with examples)
-}
-
-src_install() {
- default
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch b/dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch
deleted file mode 100644
index 34067ff1f539..000000000000
--- a/dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-Fix buildsystem, to avoid ugly and extremely brittle patching
-of the configure script and Makefile.in in the main ebuild.
-
---- a/configure.in
-+++ b/configure.in
-@@ -1,8 +1,8 @@
-+AC_PREREQ([2.69])
-+AC_INIT([fampp2],[7.0.1])
-
--# require autoconf 2.13
--AC_PREREQ(2.13)
--
--AC_INIT(src/Fampp2.hh)
-+AC_CONFIG_MACRO_DIR([macros])
-+AC_CONFIG_SRCDIR([src/Fampp2.hh])
-
- FAMPPTWO_MAJOR=7
- FAMPPTWO_MINOR=0
-@@ -22,9 +22,8 @@
- VERSION=$FAMPP_VERSION
- PACKAGE=fampp2
-
--AM_CONFIG_HEADER(config.h)
--AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
--AM_MAINTAINER_MODE
-+AC_CONFIG_HEADERS([config.h])
-+AM_INIT_AUTOMAKE
-
- AC_CANONICAL_HOST
- AC_ISC_POSIX
-@@ -33,11 +32,7 @@
- AC_PROG_CPP
- AC_PROG_CXX
-
--AC_STDC_HEADERS
--#AC_ARG_PROGRAM
--AC_DISABLE_FAST_INSTALL
--AC_DISABLE_STATIC
--AM_PROG_LIBTOOL
-+LT_INIT
-
-
- dnl Checks for libraries.
-@@ -58,15 +53,12 @@
- ###############################################################################
-
-
--CFLAGS=" $STLPORT_CFLAGS $LOKI_CFLAGS $SIGC_CFLAGS $CFLAGS -O0 -g "
--CXXFLAGS=" $STLPORT_CFLAGS $CXXFLAGS -O0 -g $LOKI_LIBS $SIGC_CFLAGS "
--LDFLAGS=" $STLPORT_LIBS $SIGC_LIBS $LDFLAGS -Wl,-O1 -Wl,--hash-style=both"
--AC_SUBST(CFLAGS)
--AC_SUBST(CPPFLAGS)
--AC_SUBST(LDFLAGS)
--AC_SUBST(CXXFLAGS)
--AC_SUBST(CXXCPPFLAGS)
-+CFLAGS="${CFLAGS} ${STLPORT_CFLAGS} ${LOKI_CFLAGS} ${SIGC_CFLAGS}"
-+CXXFLAGS="${CXXFLAGS} ${STLPORT_CFLAGS} ${LOKI_CFLAGS} ${SIGC_CFLAGS}"
-+LIBS="${LIBS} ${STLPORT_LIBS} ${LOKI_LIBS} ${SIGC_LIBS}"
-
-+AC_ARG_WITH([examples], [install examples])
-+AM_CONDITIONAL([EXAMPLES], [test "x$with_examples" = "xyes"])
-
- dnl if test "x${prefix}" = 'xNONE'; then
- dnl prefix=${ac_default_prefix};
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,7 +1,10 @@
- AUTOMAKE_OPTIONS = dist-bzip2 subdir-objects
-
- NULL=
--SUBDIRS = src examples
-+SUBDIRS = src
-+if EXAMPLES
-+SUBDIRS += examples
-+endif
-
- EXTRA_DIST = fampp.spec fampp.spec.in fampp2.pc.in fampp2.pc
-
diff --git a/dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch b/dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch
deleted file mode 100644
index 659ecd51bf4c..000000000000
--- a/dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-C++11 changed destructor semantics to be noexcept(true)
-by default, leading to potentially changed semantics.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=595308
-
---- a/src/Fampp2.cpp
-+++ b/src/Fampp2.cpp
-@@ -105,6 +105,9 @@
- // #include <unistd.h>
-
- FamppRequest::~FamppRequest()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- // cerr << "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!" << endl;
- // cerr << "FamppRequest::~FamppRequest() this:" << (void*)this << endl;
-@@ -245,6 +248,9 @@
-
-
- FamppImplMethods::~FamppImplMethods()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
- {
- if(0 != FAMClose( &theFAMConnection )) {
- throw FamppCloseFailedException();
---- a/src/Fampp2.hh
-+++ b/src/Fampp2.hh
-@@ -168,7 +168,11 @@
- public:
-
-
-- ~FamppRequest();
-+ ~FamppRequest()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
-
- void suspend();
-@@ -216,7 +220,11 @@
- protected:
-
- FamppImplMethods();
-- virtual ~FamppImplMethods();
-+ virtual ~FamppImplMethods()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
-
- public:
-@@ -251,7 +259,11 @@
- public:
- FamppSingletonClass();
- FamppSingletonClass(const std::string appName);
-- ~FamppSingletonClass();
-+ ~FamppSingletonClass()
-+#if __cplusplus >= 201103L
-+ noexcept(false)
-+#endif
-+ ;
-
-
- void NextEvent();
diff --git a/dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch b/dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch
deleted file mode 100644
index 6b76a1532cbb..000000000000
--- a/dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Remove inclusion of libsigc++ headers obsoleted with version 2.6
-See also: https://bugs.gentoo.org/show_bug.cgi?id=569700
-
---- a/examples/console_test/famppct.cpp
-+++ b/examples/console_test/famppct.cpp
-@@ -30,8 +30,6 @@
-
- #include <sigc++/sigc++.h>
- #include <sigc++/slot.h>
--#include <sigc++/object.h>
--#include <sigc++/object_slot.h>
-
- #include <gtk/gtk.h>
- #include <stdio.h>
---- a/examples/gtk/famppgtk.cpp
-+++ b/examples/gtk/famppgtk.cpp
-@@ -31,8 +31,6 @@
-
- #include <sigc++/sigc++.h>
- #include <sigc++/slot.h>
--#include <sigc++/object.h>
--#include <sigc++/object_slot.h>
-
- #include <gtk/gtk.h>
- #include <stdio.h>
---- a/src/Fampp2.cpp
-+++ b/src/Fampp2.cpp
-@@ -34,8 +34,6 @@
-
- #include <sigc++/sigc++.h>
- #include <sigc++/slot.h>
--#include <sigc++/object.h>
--#include <sigc++/object_slot.h>
-
-
- using namespace std;
---- a/src/FamppEvents.hh
-+++ b/src/FamppEvents.hh
-@@ -36,7 +36,6 @@
-
- #include <fam.h>
- #include <sigc++/signal.h>
--#include <sigc++/object.h>
- #include <SmartPtr.h>
- #include <Singleton.h>
- #include <Factory.h>
diff --git a/dev-libs/fampp2/metadata.xml b/dev-libs/fampp2/metadata.xml
deleted file mode 100644
index ff43a116ec95..000000000000
--- a/dev-libs/fampp2/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">fampp</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 90f06a87d847..98af9704cbd6 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -735,11 +735,6 @@ dev-libs/legousbtower
# Removal in 30 days. Bug #694174.
dev-libs/hashit
-# Michał Górny <mgorny@gentoo.org> (2019-09-12)
-# Unmaintained. Last release from 2010. No reverse dependencies.
-# Removal in 30 days. Bug #694170.
-dev-libs/fampp2
-
# Lars Wendler <polynomial-c@gentoo.org> (2019-09-04)
# Unofficial build. Superseded by official 2.49.5 release.
# Masked for removal.