summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-06 13:56:41 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-06 15:49:49 +0200
commitdeba3b6e387ba415b7e0325825784a222cdbbe09 (patch)
treeb69f290e13f9f2b8664951bd5a6b7358df9fb642
parentnet-firewall/shorewall: drop old (diff)
downloadgentoo-deba3b6e387ba415b7e0325825784a222cdbbe09.tar.gz
gentoo-deba3b6e387ba415b7e0325825784a222cdbbe09.tar.bz2
gentoo-deba3b6e387ba415b7e0325825784a222cdbbe09.zip
sys-block/storcli: bump to v7.1410
Upstream dropped x86 support. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-block/storcli/Manifest1
-rw-r--r--sys-block/storcli/storcli-7.1410.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-block/storcli/Manifest b/sys-block/storcli/Manifest
index 7cbf1b99be96..986a4fed064f 100644
--- a/sys-block/storcli/Manifest
+++ b/sys-block/storcli/Manifest
@@ -10,3 +10,4 @@ DIST storcli-7.0709.zip 25844769 BLAKE2B f44791d0813f348068a89a14a0ea457667ab8e2
DIST storcli-7.1017.zip 36266095 BLAKE2B e1bb4c6bbd19712530fc8d3d7917bf943221f121d0a7d5d3e44205f73bab408d7e4ff94d8cac479a1b834b82e8bdb6661805ca13f1695f8bad52d69d2c988fe9 SHA512 fb4b45fa577417627e67d20bbfa2e07512fe600ffeb9d21e11a80e25208f17b56fb25fa74a9777622c72012a605813b0206a990a6d4191f6b57371bd1d72fd6b
DIST storcli-7.1211.zip 36988201 BLAKE2B 487dda0c78af60d96dc6eb8bc0c7074dd99719acc4faf10027430ea80a5d1cb76e6bdc9eaf0931967c5cdf10d80ee824f45118144bfc032a4ddce52d678df354 SHA512 f28ae41adf2286153ecd57f7d022940069356c9636e45aaae4ae45215487bbb8e3dea51fa4aa00b9e9340069036c1be21b186ce177e0fd0a6a0bb786cb58181f
DIST storcli-7.1316.zip 37136466 BLAKE2B 7bca2e1b330f40e66945567ac8fad04d448993ff7ab4a4d846a0b6142fbe3988ab00775aa3897e3268e30b34cb7659e96f75d2383d3e85e4bec433edde5ba17e SHA512 049b34d44bb1140ad804f6bb6d8fb133ac9bbc4aface721051e713c7a1056acb0f894f4f4793ef9e02e48958a745d12bc5389e7e763716c780fb1c2c387e34d6
+DIST storcli-7.1410.zip 34424559 BLAKE2B cb0b613d0ccbf6ac36d1aace9174286ffe89d0602c7bca3b2712abcdba1b82cc2498de686e815e01fa125920c94d780e2f7fa4ab2ff570dc42818f4c4f491da4 SHA512 4887d434757f15e931c3c3c57b2316fc0cf0a5284c6009601b58c9585b73f9b9c9a0318dd3c4472cd3578aa5ec12b641a371db1d726a637741f6f0b34dd1f3e7
diff --git a/sys-block/storcli/storcli-7.1410.ebuild b/sys-block/storcli/storcli-7.1410.ebuild
new file mode 100644
index 000000000000..cd0ac4c6ba7d
--- /dev/null
+++ b/sys-block/storcli/storcli-7.1410.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit pax-utils toolchain-funcs
+
+# Upstream is still using strange version numbers
+MY_PV="007.1410.0000.0000"
+
+DESCRIPTION="MegaRAID StorCLI (successor of the MegaCLI)"
+HOMEPAGE="https://www.broadcom.com/support/download-search?dk=storcli"
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_PV}_Unified_StorCLI.zip -> ${P}.zip"
+
+LICENSE="Avago LSI BSD"
+SLOT="0/7.14"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+MY_STORCLI_BASEDIR="/opt/lsi/storcli"
+
+QA_PRESTRIPPED="${MY_STORCLI_BASEDIR:1}/storcli
+ ${MY_STORCLI_BASEDIR:1}/storcli32"
+QA_PREBUILT=${QA_PRESTRIPPED}
+
+src_unpack() {
+ mkdir srcfiles || die
+ pushd srcfiles &>/dev/null || die
+ default
+ mv Unified_storcli_all_os/Ubuntu/storcli_*.deb "${WORKDIR}" || die "Failed to move storcli_*.deb"
+ popd &>/dev/null || die
+
+ rm -rf srcfiles || die
+
+ # Unpack Ubuntu package which will be our $S content
+ unpack "${WORKDIR}"/storcli_*.deb
+ rm -f storcli_*.deb || die "Failed to cleanup storcli_*.deb package"
+ unpack "${WORKDIR}"/data.tar.xz
+
+ mkdir "${S}" || die "Failed to create '${S}'"
+}
+
+src_prepare() {
+ default
+
+ # Create clean $S
+ mv "${WORKDIR}"/opt/Mega*/storcli/* "${S}" || die "Failed to move storcli_.deb content to '${S}'"
+ rm -rf "${WORKDIR}"/{opt,control.tar.gz,data.tar.gz,debian-binary} || die "Failed to cleanup no longer needed files"
+}
+
+src_install() {
+ exeinto "${MY_STORCLI_BASEDIR}"
+ newexe storcli64 storcli
+
+ dosym "${MY_STORCLI_BASEDIR}"/storcli /usr/sbin/storcli
+
+ pax-mark m "${D}${MY_STORCLI_BASEDIR}"/storcli
+}