summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-10 07:51:29 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-10 08:32:37 +0100
commitdec21923cf1995c599eaa69517cad41acd1102b7 (patch)
tree139d5dc185cf46f1fce7ce31fc79460daf7770cb
parentapp-admin/awscli: Bump to 1.22.2 (diff)
downloadgentoo-dec21923cf1995c599eaa69517cad41acd1102b7.tar.gz
gentoo-dec21923cf1995c599eaa69517cad41acd1102b7.tar.bz2
gentoo-dec21923cf1995c599eaa69517cad41acd1102b7.zip
dev-python/proto-plus: Bump to 1.19.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/proto-plus/Manifest1
-rw-r--r--dev-python/proto-plus/proto-plus-1.19.8.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index 15c0caf13613..cd642392636c 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1,2 +1,3 @@
DIST proto-plus-1.19.2.gh.tar.gz 61183 BLAKE2B 8c1c0a70ae573fc8c64004e4bd923f403bf82dbb3f9aef19239770fcd316e513ba11e6e47c56bda65c88e476072f0d90af02c83eb0fe8a4045cf3ceeccca3fc7 SHA512 c3cfb1b6aabeb4eab7f6c2c16551c1f9fbf29dc3199b496bc4b47b4b80cbe4684e5c97abe26fa4c1afd03c844a2e8f006f16c24932d2a7cf8190452943c2fad0
DIST proto-plus-1.19.7.gh.tar.gz 64614 BLAKE2B 918bb04a084cff8a2188a68c31f08aebd25443fd399d69ba9734d002f773df2769904e4aa551cd1d93586ee4710f2b7160e6a8eb4160fe1bb846be18155a7b29 SHA512 118187a852a998deba3b5d7e700cd084eab966b549c7dba6150f318e9602f950a9533e27d775f9f0bca2fedaed6375b592bae42c55cf5aee8b52708fcc4691c8
+DIST proto-plus-1.19.8.gh.tar.gz 64668 BLAKE2B d90ba4bd2404a0b05325e08e9ec39de0b819af00e9229ca54a7173364a99e0cedb584696093f3df7720d96f8291fad4f26b9963171de8ebd44396550dc932e17 SHA512 e9bd790ec7d2cc7fa54e5c8be374e4a7bc5c92899c5259e6985024fe1c9e25768c1355b808a9a4c38b132026412b2e7d91c5fe0098af661b1dac604b84aaf2ee
diff --git a/dev-python/proto-plus/proto-plus-1.19.8.ebuild b/dev-python/proto-plus/proto-plus-1.19.8.ebuild
new file mode 100644
index 000000000000..762787eae60d
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.19.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="https://pypi.org/project/proto-plus/ https://github.com/googleapis/proto-plus-python"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme