summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-03 21:20:31 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-03 22:54:04 +0200
commitdecdf1e4e5f15e98d7302930ef0a345721fa66fd (patch)
treef218bef571e73778717f6f57255962d0d73c6c84
parentsys-devel/gcc: 6.5.0: fix patchset numbering (diff)
downloadgentoo-decdf1e4.tar.gz
gentoo-decdf1e4.tar.bz2
gentoo-decdf1e4.zip
www-client/links: replace echo for printf.
Courtesy of Lars Wendler <polynomial-c@gentoo.org>. Closes: https://bugs.gentoo.org/667304 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--www-client/links/files/swap-echo-for-printf.patch26
-rw-r--r--www-client/links/links-2.20.2-r1.ebuild2
2 files changed, 28 insertions, 0 deletions
diff --git a/www-client/links/files/swap-echo-for-printf.patch b/www-client/links/files/swap-echo-for-printf.patch
new file mode 100644
index 000000000000..9681a624ed2b
--- /dev/null
+++ b/www-client/links/files/swap-echo-for-printf.patch
@@ -0,0 +1,26 @@
+"echo -n" is not POSIX compliant but printf is.
+See "man 1p echo" section "APPLICATION USAGE" or visit
+https://www.in-ulm.de/%7Emascheck/various/echo+printf/
+
+--- a/intl/synclang.orig 2020-06-03 19:13:38.082539276 -0000
++++ b/intl/synclang 2020-06-03 19:13:59.122352023 -0000
+@@ -6,7 +6,7 @@
+ if [ -n "$languages" ]; then
+ for i in $languages; do
+ if [ "$i" != english ]; then
+- echo -n $i" " 1>&2
++ printf '%s ' "$i" 1>&2
+ awk -f synclang.awk <$i.lng | sed 's/ //g' >_sync.tmp
+ mv $i.lng ../intl-bak/$i.lng.bak
+ mv _sync.tmp $i.lng
+--- a/intl/gen-intl.orig 2020-06-03 19:14:37.258679373 -0000
++++ b/intl/gen-intl 2020-06-03 19:14:47.651920249 -0000
+@@ -10,7 +10,7 @@
+ n=0
+ echo '/* Automatically generated by gen-intl */'
+ for i in $languages; do
+- echo -n $i" " 1>&2
++ printf '%s ' "$i" 1>&2
+ if test `cat $i.lng|wc -l` != `cat english.lng|wc -l`; then
+ echo 1>&2
+ echo 1>&2
diff --git a/www-client/links/links-2.20.2-r1.ebuild b/www-client/links/links-2.20.2-r1.ebuild
index a36d03fe29a6..0c528094f163 100644
--- a/www-client/links/links-2.20.2-r1.ebuild
+++ b/www-client/links/links-2.20.2-r1.ebuild
@@ -83,6 +83,8 @@ REQUIRED_USE="!livecd? ( fbcon? ( gpm ) )
DOCS=( AUTHORS BRAILLE_HOWTO ChangeLog KEYS NEWS README SITES )
+PATCHES=( "${FILESDIR}/swap-echo-for-printf.patch" )
+
src_prepare() {
use X && xdg_environment_reset