summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-23 23:12:32 +0100
committerSam James <sam@gentoo.org>2022-05-23 23:12:32 +0100
commitdedbdc466c8e0bdac003e60c0f158548967dc348 (patch)
tree4f2ccf0cb99e2ce0f6d2e90b64aea474562359de
parentsci-libs/gdal: needs hdf5[cxx] (diff)
downloadgentoo-dedbdc466c8e0bdac003e60c0f158548967dc348.tar.gz
gentoo-dedbdc466c8e0bdac003e60c0f158548967dc348.tar.bz2
gentoo-dedbdc466c8e0bdac003e60c0f158548967dc348.zip
net-p2p/qbittorrent: add 4.4.3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.4.3.ebuild107
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild69
3 files changed, 159 insertions, 18 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index f9aaa711e403..c0d49325ec40 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -2,3 +2,4 @@ DIST qbittorrent-4.3.8.tar.gz 8506355 BLAKE2B e59be1556ad0be697e32d69d890115df6c
DIST qbittorrent-4.3.9.tar.gz 8510414 BLAKE2B de98aff6d81f43c3ad87f6c5f800a4488e18173fb96713d0a2420cf4d4708c9b1f2f54c8d0aa566e7738b4f94d192aad9f0196a05d43724582ef81833901727f SHA512 ec33f67895fbf47acc2f79d9c9e16db8b96c756cf493b76eb24b90e13a790a709104ea9aa378ee111d8c38b605bed5192b366d1917bbf160b21aa2ae3aacd2d1
DIST qbittorrent-4.4.1.tar.gz 9090594 BLAKE2B 1b0d4900352c069177913a2ef66bd986a45d13d52f191b824a4dbd38d84b037a7410a9c71cf487d537a5ce70b00e8f695c20acd85ede963731a84f39c9b8ee5c SHA512 155e0394e1599fbbae4b03fc39a13085eb4f797fdf7ff45d2c552c66cdb523e146b77da4fa0f14d6b5b64e3b56f9da7163fd544811a40a9a787848007bfbd0a6
DIST qbittorrent-4.4.2.tar.gz 9197188 BLAKE2B 719ca031b1a5523cd29582d7d57ac48e5d3cfb8b1c62e23f01d116897e7753cda204a0dc401f364860eba750371f41178d87ae6d1f43241506868d90a8bc9e32 SHA512 55656fb5fd282a3ed0e703b9b47ec9733a70cf6242cae956a5b2487ef2aeb88a04bf5d37c8fa88554edf95ab0821b76ebebb53e8fc43dc5889f8c730075d6e26
+DIST qbittorrent-4.4.3.tar.gz 7757274 BLAKE2B aa6705e8c36cc5905e4767f5c09066d259143004550490c3dd3f225196053fc4b4bca9afa5f0b19a32267332e40576dc929a2597847fd1ce107fb36b351ba031 SHA512 e3de225f2a2cabc7de3d9a555ad83620465c229f7c2b382362e550f320b1ce620282927753a26c2f320675b96fb6f91bad9bd0533d7400eea14120594f9d1275
diff --git a/net-p2p/qbittorrent/qbittorrent-4.4.3.ebuild b/net-p2p/qbittorrent/qbittorrent-4.4.3.ebuild
new file mode 100644
index 000000000000..e66a7bbca615
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.4.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake multibuild systemd xdg
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus +gui webui"
+REQUIRED_USE="dbus? ( gui )
+ || ( gui webui )"
+
+RDEPEND="
+ >=dev-libs/boost-1.65.0-r1:=
+ dev-libs/openssl:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.2.14:=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ gui? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_prepare() {
+ MULTIBUILD_VARIANTS=( base )
+ use webui && MULTIBUILD_VARIANTS+=( webui )
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ multibuild_src_configure() {
+ local mycmakeargs=(
+ -DDBUS=$(usex dbus)
+
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+
+ # We always want to install unit files
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
+
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+
+ # Not yet in ::gentoo
+ -DQT6=OFF
+
+ # We do these in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ -DGUI=$(usex gui)
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} == webui ]] ; then
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DWEBUI=ON
+ )
+ else
+ mycmakeargs+=( -DWEBUI=OFF )
+ fi
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant multibuild_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+
+ if ! use webui ; then
+ # No || die deliberately as it doesn't always exist
+ rm "${D}/$(systemd_get_systemunitdir)"/qbittorrent-nox*.service
+ fi
+
+ einstalldocs
+}
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 85869e0799fd..e66a7bbca615 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake systemd xdg
+inherit cmake multibuild systemd xdg
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="https://www.qbittorrent.org
@@ -21,7 +21,8 @@ fi
LICENSE="GPL-2"
SLOT="0"
IUSE="+dbus +gui webui"
-REQUIRED_USE="dbus? ( gui )"
+REQUIRED_USE="dbus? ( gui )
+ || ( gui webui )"
RDEPEND="
>=dev-libs/boost-1.65.0-r1:=
@@ -45,30 +46,62 @@ BDEPEND="dev-qt/linguist-tools:5
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+src_prepare() {
+ MULTIBUILD_VARIANTS=( base )
+ use webui && MULTIBUILD_VARIANTS+=( webui )
+
+ cmake_src_prepare
+}
+
src_configure() {
- local mycmakeargs=(
- -DDBUS=$(usex dbus)
- -DGUI=$(usex gui)
- -DWEBUI=$(usex webui)
+ multibuild_src_configure() {
+ local mycmakeargs=(
+ -DDBUS=$(usex dbus)
+
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+
+ # We always want to install unit files
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
- # musl lacks execinfo.h
- -DSTACKTRACE=$(usex !elibc_musl)
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
- # We always want to install unit files
- -DSYSTEMD=ON
- -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
+ # Not yet in ::gentoo
+ -DQT6=OFF
- # More verbose build logs are preferable for bug reports
- -DVERBOSE_CONFIGURE=ON
+ # We do these in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ -DGUI=$(usex gui)
+ )
- # Not yet in ::gentoo
- -DQT6=OFF
- )
+ if [[ ${MULTIBUILD_VARIANT} == webui ]] ; then
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DWEBUI=ON
+ )
+ else
+ mycmakeargs+=( -DWEBUI=OFF )
+ fi
- cmake_src_configure
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant multibuild_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
}
src_install() {
- cmake_src_install
+ multibuild_foreach_variant cmake_src_install
+
+ if ! use webui ; then
+ # No || die deliberately as it doesn't always exist
+ rm "${D}/$(systemd_get_systemunitdir)"/qbittorrent-nox*.service
+ fi
+
einstalldocs
}