summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-18 14:33:13 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-18 14:34:46 +0200
commitdee630c7fee42ae9196065e93bbd61cff34194de (patch)
tree35837a8e40743e0433939a1783340b69659788b6
parent*/*: reassign jcallen@g.o's packages (diff)
downloadgentoo-dee630c7fee42ae9196065e93bbd61cff34194de.tar.gz
gentoo-dee630c7fee42ae9196065e93bbd61cff34194de.tar.bz2
gentoo-dee630c7fee42ae9196065e93bbd61cff34194de.zip
dev-db/mysql: using SSL is mandatory
Closes: https://bugs.gentoo.org/692390 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-db/mysql/mysql-8.0.17.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-db/mysql/mysql-8.0.17.ebuild b/dev-db/mysql/mysql-8.0.17.ebuild
index df67c9534ad5..9bf70ba0f6b2 100644
--- a/dev-db/mysql/mysql-8.0.17.ebuild
+++ b/dev-db/mysql/mysql-8.0.17.ebuild
@@ -30,7 +30,7 @@ DESCRIPTION="A fast, multi-threaded, multi-user SQL database server"
LICENSE="GPL-2"
SLOT="0"
IUSE="cjk cracklib debug jemalloc latin1 libressl numa +perl profiling
- router selinux ssl tcmalloc test"
+ router selinux tcmalloc test"
# Tests always fail when libressl is enabled due to hard-coded ciphers in the tests
RESTRICT="libressl? ( test )"
@@ -77,10 +77,8 @@ COMMON_DEPEND="
sys-process/procps:0=
)
numa? ( sys-process/numactl )
- ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.0:0= )
- libressl? ( dev-libs/libressl:0= )
- )
+ !libressl? ( >=dev-libs/openssl-1.0.0:0= )
+ libressl? ( dev-libs/libressl:0= )
tcmalloc? ( dev-util/google-perftools:0= )
"
DEPEND="${COMMON_DEPEND}
@@ -224,10 +222,9 @@ src_configure(){
-DINSTALL_SUPPORTFILESDIR="${EPREFIX}/usr/share/mysql"
-DCOMPILATION_COMMENT="Gentoo Linux ${PF}"
-DWITH_UNIT_TESTS=$(usex test ON OFF)
- ### TODO: make this system but issues with UTF-8 prevent it
-DWITH_EDITLINE=system
-DWITH_ZLIB=system
- -DWITH_SSL=$(usex ssl system wolfssl)
+ -DWITH_SSL=system
-DWITH_LIBWRAP=0
-DENABLED_LOCAL_INFILE=1
-DMYSQL_UNIX_ADDR="${EPREFIX}/var/run/mysqld/mysqld.sock"