summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-08 17:38:55 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-08 17:38:55 +0900
commitdeecd87cdfb44e52a4ec502179d70265030dcaa5 (patch)
treef4da5b61d420478c036b95fb605bfbe2b754c702
parentdev-libs/libspt: update to EAPI 6 (diff)
downloadgentoo-deecd87c.tar.gz
gentoo-deecd87c.tar.bz2
gentoo-deecd87c.zip
dev-libs/libspt: add suid USE flag
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-libs/libspt/libspt-1.1-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libspt/libspt-1.1-r3.ebuild b/dev-libs/libspt/libspt-1.1-r3.ebuild
new file mode 100644
index 000000000000..00623ecb65c7
--- /dev/null
+++ b/dev-libs/libspt/libspt-1.1-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Library for handling root privilege"
+#HOMEPAGE="http://www.j10n.org/libspt/index.html"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="suid"
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-gentoo.patch" )
+
+src_install() {
+ default
+
+ if use suid; then
+ fperms 4755 /usr/libexec/sptagent
+ fi
+}