summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-02-28 17:50:24 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-28 18:14:47 +0100
commitdef44310c577435bc45fc2f37190588cb8399a3c (patch)
treebaf93e9e99b72ba7f048aeefa554bfdf9bb974e0
parentapp-eselect/eselect-python: Support pythonX.Y-config in the old version (diff)
downloadgentoo-def44310.tar.gz
gentoo-def44310.tar.bz2
gentoo-def44310.zip
app-eselect/eselect-python: Remove old ~arch versions
-rw-r--r--app-eselect/eselect-python/eselect-python-20131210.ebuild53
-rw-r--r--app-eselect/eselect-python/eselect-python-20140115.ebuild51
-rw-r--r--app-eselect/eselect-python/eselect-python-20140125.ebuild51
3 files changed, 0 insertions, 155 deletions
diff --git a/app-eselect/eselect-python/eselect-python-20131210.ebuild b/app-eselect/eselect-python/eselect-python-20131210.ebuild
deleted file mode 100644
index 2fbad7920fe9..000000000000
--- a/app-eselect/eselect-python/eselect-python-20131210.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# Keep the EAPI low here because everything else depends on it.
-# We want to make upgrading simpler.
-
-if [[ ${PV} == "99999999" ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="Eselect module for management of multiple Python versions"
-HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=app-admin/eselect-1.2.3"
-# Avoid autotool deps for released versions for circ dep issues.
-if [[ ${PV} == "99999999" ]] ; then
- DEPEND="sys-devel/autoconf"
-else
- DEPEND=""
-fi
-
-src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
- git-r3_src_unpack
- cd "${S}"
- eautoreconf
- else
- unpack ${A}
- fi
-}
-
-src_install() {
- keepdir /etc/env.d/python
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- local ret=0
- ebegin "Running 'eselect python update'"
- eselect python update --python2 --if-unset || ret=1
- eselect python update --python3 --if-unset || ret=1
- eend ${ret}
-}
diff --git a/app-eselect/eselect-python/eselect-python-20140115.ebuild b/app-eselect/eselect-python/eselect-python-20140115.ebuild
deleted file mode 100644
index 3fbf4085bb5a..000000000000
--- a/app-eselect/eselect-python/eselect-python-20140115.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# Keep the EAPI low here because everything else depends on it.
-# We want to make upgrading simpler.
-
-if [[ ${PV} == "99999999" ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="Eselect module for management of multiple Python versions"
-HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=app-admin/eselect-1.2.3"
-
-src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
- git-r3_src_unpack
- cd "${S}"
- eautoreconf
- else
- unpack ${A}
- fi
-}
-
-src_install() {
- keepdir /etc/env.d/python
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- if has_version 'dev-lang/python'; then
- eselect python update --if-unset
- fi
- if has_version '=dev-lang/python-2*'; then
- eselect python update --python2 --if-unset
- fi
- if has_version '=dev-lang/python-3*'; then
- eselect python update --python3 --if-unset
- fi
-}
diff --git a/app-eselect/eselect-python/eselect-python-20140125.ebuild b/app-eselect/eselect-python/eselect-python-20140125.ebuild
deleted file mode 100644
index 6b16b3d05248..000000000000
--- a/app-eselect/eselect-python/eselect-python-20140125.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# Keep the EAPI low here because everything else depends on it.
-# We want to make upgrading simpler.
-
-if [[ ${PV} == "99999999" ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Eselect module for management of multiple Python versions"
-HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=app-admin/eselect-1.2.3"
-
-src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
- git-r3_src_unpack
- cd "${S}"
- eautoreconf
- else
- unpack ${A}
- fi
-}
-
-src_install() {
- keepdir /etc/env.d/python
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- if has_version 'dev-lang/python'; then
- eselect python update --if-unset
- fi
- if has_version '=dev-lang/python-2*'; then
- eselect python update --python2 --if-unset
- fi
- if has_version '=dev-lang/python-3*'; then
- eselect python update --python3 --if-unset
- fi
-}