summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-01-30 01:57:30 +0100
committerLouis Sautier <sautier.louis@gmail.com>2016-01-30 16:17:05 +0100
commitdf01b66c61f21bdde0cd52b214826477fb99b0d0 (patch)
treeb1dd819beeb6674c99eb9a6358ae6e7d050b37ca
parentdev-ros/gazebo_plugins: backport upstream fixes to build with gazebo7 (diff)
downloadgentoo-df01b66c.tar.gz
gentoo-df01b66c.tar.bz2
gentoo-df01b66c.zip
dev-python/blessings: add py3.5, fix tests
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/blessings/blessings-1.6.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/blessings/blessings-1.6.ebuild b/dev-python/blessings/blessings-1.6.ebuild
index a7c135ae3b49..7a08c1be567c 100644
--- a/dev-python/blessings/blessings-1.6.ebuild
+++ b/dev-python/blessings/blessings-1.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
@@ -17,9 +17,11 @@ LICENSE="MIT"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
-DEPEND="dev-python/nose[${PYTHON_USEDEP}]"
-RDEPEND=""
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
- nosetests --verbosity=3 ${PN} || die
+ # The tests need an interactive terminal
+ # https://github.com/erikrose/blessings/issues/117
+ script -eqc "nosetests -w \"${BUILD_DIR}\"" /dev/null \
+ || die "tests failed with ${EPYTHON}"
}