summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-23 19:56:17 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-23 19:58:40 -0400
commitdf0fe75d41ef08e8ddc078a4749fafdb6b2c9d50 (patch)
tree03d6f799b96bc88a05485e437c2ff752a46a0910
parentprofiles: fix s390x split-usr profile (diff)
downloadgentoo-df0fe75d.tar.gz
gentoo-df0fe75d.tar.bz2
gentoo-df0fe75d.zip
x11-apps/xdm: Version bump to 1.1.15
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-apps/xdm/Manifest1
-rw-r--r--x11-apps/xdm/xdm-1.1.15.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/x11-apps/xdm/Manifest b/x11-apps/xdm/Manifest
index 1a1db64a0714..61952ce02c27 100644
--- a/x11-apps/xdm/Manifest
+++ b/x11-apps/xdm/Manifest
@@ -1 +1,2 @@
DIST xdm-1.1.14.tar.xz 419324 BLAKE2B e1c4f1db1af670171e80b7ab759f8e477c84997a873401eb27042590eebe457b38dc7bc998c42e954012ce06c1f4c216655a9c2809a22d88e372c9f7b57e0ff0 SHA512 8ed1d2c946916c24cb4b2de9326f65629c97e53b145312c9cb9c6e4308d8b47d67d3981319fbd4feac9b3ed436b9dfb24a1c905d37d7bcf07b49c18a68c7a6e4
+DIST xdm-1.1.15.tar.xz 420844 BLAKE2B d171f46322fb346e7844ebf4095f9b3f86992984a59d5b42644e82ef2efbada8d0c0c465a0caa73ee0d6ed8e137ee883ef2efdd38bb240decb1b8047b518ee2e SHA512 b36c978b6a54e3db43f929c52cbf47ea226dc0fe018f8284d8c495c73f269af33a7441d5a5072d8e9b2a34e9c71767de9d8762bc3ed196b1bebc78b016f7d8bb
diff --git a/x11-apps/xdm/xdm-1.1.15.ebuild b/x11-apps/xdm/xdm-1.1.15.ebuild
new file mode 100644
index 000000000000..768e12532ef5
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.15.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3 pam systemd
+
+DEFAULTVT=vt7
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="pam systemd truetype xinerama xpm"
+
+RDEPEND="
+ x11-apps/sessreg
+ x11-apps/xconsole
+ x11-apps/xinit
+ x11-apps/xrdb
+ x11-apps/xsm
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXaw
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ virtual/libcrypt:=
+ pam? ( sys-libs/pam )
+ systemd? ( >=sys-apps/systemd-209:= )
+ truetype? (
+ x11-libs/libXrender
+ x11-libs/libXft
+ )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+ elibc_glibc? ( dev-libs/libbsd )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ sed -i -e 's:^Alias=.*$:Alias=display-manager.service:' \
+ xdm.service.in || die
+
+ # Disable XDM-AUTHORIZATION-1 (bug #445662).
+ # it causes issue with libreoffice and SDL games (bug #306223).
+ sed -i -e '/authorize/a DisplayManager*authName: MIT-MAGIC-COOKIE-1' \
+ config/xdm-config.in || die
+
+ xorg-3_src_prepare
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ $(use_with pam)
+ $(use_with systemd systemd-daemon)
+ $(use_with truetype xft)
+ $(use_with xinerama)
+ $(use_enable xpm xpm-logos)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession
+
+ use pam && pamd_mimic system-local-login xdm auth account session
+
+ # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
+ keepdir /var/lib/xdm
+}