summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-10 21:55:31 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-10 21:55:41 +0200
commitdf1e8831e12258beaaa9d5910ca6ba25f113e62a (patch)
tree2c5a799d4770cdc411b3846e4757e3f70ad2eead
parentapp-text/lout: Remove old (diff)
downloadgentoo-df1e8831e12258beaaa9d5910ca6ba25f113e62a.tar.gz
gentoo-df1e8831e12258beaaa9d5910ca6ba25f113e62a.tar.bz2
gentoo-df1e8831e12258beaaa9d5910ca6ba25f113e62a.zip
app-text/sablotron: EAPI bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--app-text/sablotron/sablotron-1.0.3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/sablotron/sablotron-1.0.3-r1.ebuild b/app-text/sablotron/sablotron-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..4bceeb87bd16
--- /dev/null
+++ b/app-text/sablotron/sablotron-1.0.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_PN="Sablot"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An XSLT Parser in C++"
+HOMEPAGE="http://www.gingerall.org/sablotron.html"
+SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
+
+# Sablotron can optionally be built under GPL, using MPL for now
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl"
+
+RDEPEND=">=dev-libs/expat-1.95.6-r1"
+DEPEND="${RDEPEND}
+ >=dev-perl/XML-Parser-2.3"
+
+PATCHES=( "${FILESDIR}/1.0.3-libsablot-expat.patch" )
+
+src_prepare() {
+ default
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable perl perlconnect) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README README_JS RELEASE src/TODO
+}