summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-22 16:37:15 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-22 17:21:05 +0100
commitdf1f4a2dfc0c2d77ae20cdcc72dc8102c45fbb2d (patch)
treefa891af19a14ba76cf3e4439713c27259e6ec158
parentdev-python/pytest-httpbin: Bump to 1.0.0, fix tests (diff)
downloadgentoo-df1f4a2d.tar.gz
gentoo-df1f4a2d.tar.bz2
gentoo-df1f4a2d.zip
dev-python/requests: Bump to 2.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/requests/Manifest1
-rw-r--r--dev-python/requests/files/requests-2.22.0-pytest-4.patch27
-rw-r--r--dev-python/requests/requests-2.22.0.ebuild67
3 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
index 9797fc1d7b84..9d1106977fd4 100644
--- a/dev-python/requests/Manifest
+++ b/dev-python/requests/Manifest
@@ -1 +1,2 @@
DIST requests-2.21.0.tar.gz 111528 BLAKE2B 7b40f9f572a8efde41c177fb5d1e1eaf29ca60cad0661fa28ac0085f3700348380d619f68c0082f24044d1af82b16d6b1e7d5dd2c2a2329f85fcee7141b1fbf6 SHA512 385e1d80993a21c09e7c4682500ca8c24155962ba41ecd8e73612722b2ff6618b736e827fc48ad1683b0d2bc7a420cfe680f5107860aca52656ef777f1d60104
+DIST requests-2.22.0.tar.gz 113406 BLAKE2B 36e1fa106f30af3d560c11edab3cd8f7e79116378c6f4d505052c8b19021846a22b4631567859b23331e7c9413896e77d7fc3288cd3af586f5f99da21c9181a6 SHA512 8b8e9da8a0c816fb4ff39be89ac7e1a9d5a99503ed93e44a0d78b28818f1c0eb253b151972a144151a616ba1b4bc5595245458a8268c5161391db54f740ac9a5
diff --git a/dev-python/requests/files/requests-2.22.0-pytest-4.patch b/dev-python/requests/files/requests-2.22.0-pytest-4.patch
new file mode 100644
index 000000000000..5b8ec34912d9
--- /dev/null
+++ b/dev-python/requests/files/requests-2.22.0-pytest-4.patch
@@ -0,0 +1,27 @@
+From dc75b3ca0b4c95648eb07b92cb414394d99c13a0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Mon, 8 Apr 2019 18:04:22 +0200
+Subject: [PATCH] Support pytest 4
+
+Fixes https://github.com/kennethreitz/requests/issues/5048
+
+See https://docs.pytest.org/en/latest/deprecations.html#marks-in-pytest-mark-parametrize
+---
+ setup.py | 2 +-
+ tests/test_utils.py | 3 ++-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_utils.py b/tests/test_utils.py
+index 59b0b0efa..62c51494d 100644
+--- a/tests/test_utils.py
++++ b/tests/test_utils.py
+@@ -33,7 +33,8 @@ class TestSuperLen:
+ 'stream, value', (
+ (StringIO.StringIO, 'Test'),
+ (BytesIO, b'Test'),
+- pytest.mark.skipif('cStringIO is None')((cStringIO, 'Test')),
++ pytest.param(cStringIO, 'Test',
++ marks=pytest.mark.skipif('cStringIO is None')),
+ ))
+ def test_io_streams(self, stream, value):
+ """Ensures that we properly deal with different kinds of IO streams."""
diff --git a/dev-python/requests/requests-2.22.0.ebuild b/dev-python/requests/requests-2.22.0.ebuild
new file mode 100644
index 000000000000..b6aeadd10964
--- /dev/null
+++ b/dev-python/requests/requests-2.22.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="socks5 +ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
+ >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
+ <dev-python/chardet-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ <dev-python/idna-2.9[${PYTHON_USEDEP}]
+ <dev-python/urllib3-1.26[${PYTHON_USEDEP}]
+ socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
+ ssl? (
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[$(python_gen_usedep 'python*' pypy)]
+ )
+"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/requests-2.22.0-pytest-4.patch
+)
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # strip tests that require some kind of network
+ sed -e 's:test_connect_timeout:_&:' \
+ -e 's:test_total_timeout_connect:_&:' \
+ -i tests/test_requests.py || die
+ # probably pyopenssl version dependent
+ sed -e 's:test_https_warnings:_&:' \
+ -i tests/test_requests.py || die
+}
+
+python_test() {
+ # tests hang with pypy & pypy3
+ [[ ${EPYTHON} == pypy* ]] && continue
+
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}