summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-29 20:57:47 +0000
committerSam James <sam@gentoo.org>2022-12-29 20:59:43 +0000
commitdf20a847068abe1101d2761bd060796ef52e4ea2 (patch)
tree1b19810ab0f12ece7a15ce9ec0e51a207d843159
parentapp-text/mupdf: rename drm macro to GENTOO_MUPDF_DRM (diff)
downloadgentoo-df20a847068abe1101d2761bd060796ef52e4ea2.tar.gz
gentoo-df20a847068abe1101d2761bd060796ef52e4ea2.tar.bz2
gentoo-df20a847068abe1101d2761bd060796ef52e4ea2.zip
app-text/hunspell: add 1.7.2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/hunspell/Manifest1
-rw-r--r--app-text/hunspell/hunspell-1.7.2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-text/hunspell/Manifest b/app-text/hunspell/Manifest
index 221793b182bf..d6c9e02a50b8 100644
--- a/app-text/hunspell/Manifest
+++ b/app-text/hunspell/Manifest
@@ -1,2 +1,3 @@
DIST hunspell-1.7.0.tar.gz 482156 BLAKE2B daf689ab44872c78d27bd035d996c61da9b01b7bbe5ced120034b2d64bbead573ad3807dfe5a06ecdbd96c610f42e4ea015be4b2046ebafad13347c08e60913a SHA512 8149b2e8b703a0610c9ca5160c2dfad3cf3b85b16b3f0f5cfcb7ebb802473b2d499e8e2d0a637a97a37a24d62424e82d3880809210d3f043fa17a4970d47c903
DIST hunspell-1.7.1.tar.gz 1074306 BLAKE2B 55b82ece0ca73fb8823fc2efaafa25dd317fb62a3f593f582049244374b7c8254fa570f86909f93ae68bcf43a625db6eec74efa2669f360a0e634f2c24bc6121 SHA512 e177fadd39e89abf47c6cec7d12d1976d21af5c924fb62402433af202c07db50156cd9f60ceae44952b05740e76a98548afb7ac12b666a9fa170ef52e6f8e808
+DIST hunspell-1.7.2.tar.gz 1536202 BLAKE2B dba8b2b505a040e3a4df488f702dafe4fd226271e67a68e1c1f9c953cc86dfa6f0049d205a8c6616b779d559b82cc8595bf2b4e86ed63e3b42cc9e20b1fecc18 SHA512 49b3619bff12e111b6cc3f3d9463612b116f9b2a976896718e65f5bc4a83ece11100aaf56a4d18127ea39107446c495e12affe5ff3c9159ae8aba70e512f44ac
diff --git a/app-text/hunspell/hunspell-1.7.2.ebuild b/app-text/hunspell/hunspell-1.7.2.ebuild
new file mode 100644
index 000000000000..fa4279305dc0
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.7.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LANGS="af bg ca cs cy da de de-1901 el en eo es et fo fr ga gl he hr hu ia id is
+it kk km ku lt lv mi mk ms nb nl nn pl pt pt-BR ro ru sk sl sq sv sw tn uk zu"
+inherit autotools flag-o-matic
+
+DESCRIPTION="Spell checker, morphological analyzer library and command-line tool"
+HOMEPAGE="https://hunspell.github.io/"
+SRC_URI="https://github.com/hunspell/hunspell/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="ncurses nls readline static-libs"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ ncurses? ( sys-libs/ncurses:= )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+PDEPEND=""
+for lang in ${LANGS}; do
+ IUSE+=" l10n_${lang}"
+ case ${lang} in
+ de-1901) dict="de_1901" ;;
+ pt-BR) dict="pt-br" ;;
+ *) dict="${lang}" ;;
+ esac
+ PDEPEND+=" l10n_${lang}? ( app-dicts/myspell-${dict} )"
+done
+unset dict lang LANGS
+
+DOCS=( AUTHORS ChangeLog NEWS THANKS license.{hunspell,myspell} README )
+
+PATCHES=(
+ # Upstream package creates some executables which names are too generic
+ # to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
+ # It modifies a Makefile.am file, hence eautoreconf.
+ "${FILESDIR}/${PN}-1.7.0-renameexes.patch"
+
+ "${FILESDIR}/${PN}-1.7.0-tinfo.patch" # bug #692614
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Missing somehow...
+ [[ ${CHOST} == *-darwin* ]] && append-libs -liconv
+
+ # I wanted to put the include files in /usr/include/hunspell.
+ # You can do that, libreoffice can find them anywhere, just
+ # ping me when you do so ; -- scarabeus
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_with ncurses ui)
+ $(use_with readline readline)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ einstalldocs
+
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ # bug #342449
+ pushd "${ED}"/usr/$(get_libdir)/ >/dev/null || die
+ ln -s lib${PN}{-$(ver_cut 1).$(ver_cut 2).so.0.0.1,.so} || die
+ popd >/dev/null || die
+}