summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-31 05:59:24 +0100
committerSam James <sam@gentoo.org>2023-05-31 05:59:46 +0100
commitdf365a51faeea136105c02ea20f8d413120b29df (patch)
tree065a14f34e5fc31c4b4b9f080e093283f785de1b
parentapp-misc/binwalk: drop 2.3.3, 2.3.3-r1 (diff)
downloadgentoo-df365a51.tar.gz
gentoo-df365a51.tar.bz2
gentoo-df365a51.zip
app-shells/bash: skip flaky hanging test
Closes: https://bugs.gentoo.org/907403 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/bash/bash-5.2_p15-r3.ebuild3
-rw-r--r--app-shells/bash/bash-9999.ebuild9
2 files changed, 9 insertions, 3 deletions
diff --git a/app-shells/bash/bash-5.2_p15-r3.ebuild b/app-shells/bash/bash-5.2_p15-r3.ebuild
index cbea068edf2f..7df4466ab275 100644
--- a/app-shells/bash/bash-5.2_p15-r3.ebuild
+++ b/app-shells/bash/bash-5.2_p15-r3.ebuild
@@ -165,6 +165,9 @@ src_prepare() {
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/* || die
+ # Sometimes hangs (more noticeable w/ pgo), bug #907403.
+ rm tests/run-jobs || die
+
eapply -p0 "${PATCHES[@]}"
eapply_user
}
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index 7235d2213a36..82dfe5fb1c66 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -33,7 +33,7 @@ is_release() {
# The version of readline this bash normally ships with.
# Note: right now, we don't use the system copy of readline for bash for non-releases.
-READLINE_VER="8.2"
+READLINE_VER="8.2_p1"
DESCRIPTION="The standard GNU Bourne again shell"
HOMEPAGE="https://tiswww.case.edu/php/chet/bash/bashtop.html https://git.savannah.gnu.org/cgit/bash.git"
@@ -92,8 +92,8 @@ RDEPEND="
${DEPEND}
"
# We only need yacc when the .y files get patched (bash42-005, bash51-011)
-#BDEPEND="app-alternatives/yacc"
BDEPEND="
+ app-alternatives/yacc
pgo? ( dev-util/gperf )
verify-sig? ( sec-keys/openpgp-keys-chetramey )
"
@@ -106,7 +106,7 @@ QA_CONFIGURE_OPTIONS="--disable-static"
PATCHES=(
#"${WORKDIR}"/${PN}-${GENTOO_PATCH_VER}/
- # Patches from Chet sent to bashbug ml
+ # Patches from Chet sent to bash-bug ml
"${FILESDIR}"/${PN}-5.0-syslog-history-extern.patch
)
@@ -163,6 +163,9 @@ src_prepare() {
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/* || die
+ # Sometimes hangs (more noticeable w/ pgo), bug #907403.
+ rm tests/run-jobs || die
+
eapply -p0 "${PATCHES[@]}"
eapply_user
}