summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-05 11:34:23 +0000
committerSam James <sam@gentoo.org>2024-01-05 11:34:23 +0000
commitdf3d5fb6d224528170f58d8372558aeb525d8e46 (patch)
tree7416df46604a23709ce8c4844545427e20cd74fb
parentdev-lang/janet: drop 1.22.0 (diff)
downloadgentoo-df3d5fb6d224528170f58d8372558aeb525d8e46.tar.gz
gentoo-df3d5fb6d224528170f58d8372558aeb525d8e46.tar.bz2
gentoo-df3d5fb6d224528170f58d8372558aeb525d8e46.zip
x11-apps/luit: add 20240102
Closes: https://bugs.gentoo.org/898844 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-apps/luit/Manifest2
-rw-r--r--x11-apps/luit/luit-20240102.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-apps/luit/Manifest b/x11-apps/luit/Manifest
index 59f4a1192bdd..6aaca2d539be 100644
--- a/x11-apps/luit/Manifest
+++ b/x11-apps/luit/Manifest
@@ -2,3 +2,5 @@ DIST luit-20221028.tgz 209510 BLAKE2B cf2785ac5c9c1081e2845d3b72b968a621add55657
DIST luit-20221028.tgz.asc 729 BLAKE2B 0bc964a275cc46616ca4730c2dde55cda1fc95e254a9c5f4e5e7bed17ad34ce7d540de6aecd9a3dee6ac13eb0e5b68de40d16e4236c7896a957f7b82fcbeaf19 SHA512 6f627cb8fa36f4f46321e3170dbc8d3a4a59f82bec885131c5751df81e37ad1a37f8dc7362458ef04e6d35960a5482dfead61b32ee2420014a22d4267d40c5a2
DIST luit-20230201.tgz 209547 BLAKE2B b303ed8b7a85acfb2f3a43476d4f22596c2e41609dc7b7dcfcbd32b6fad6d7efe47aa46338aef028d2a1f86130f3617ae00ce089b590a3a77f8bae8819270bb9 SHA512 919b3ffcf1ea7f490c959e38eda92cc023aa8b777f3d1de85fd9dd3384604c6e13c9db942bdd4756f76e1d57ae64a395c549d61a1f1f5ff982e9efd3410087c6
DIST luit-20230201.tgz.asc 729 BLAKE2B a6234bab0ef7b83c6a1518d7603774791638cd25876397b60add236ae1da494061376b6b5d855b9cede9438a35ad33634c07a1d085019c938c10f184f4819bd4 SHA512 985149784ab17aefe833226a2cc63e699ab1c1a8aa785d305f2be186e99310171b1d89eebf0c1992bb7b8e0caac0ccb42f1bc73e4074033b2e5eb41f66493bc1
+DIST luit-20240102.tgz 210935 BLAKE2B 560815d78e00ee7925b1efc43f7544b4c3d7f7d3e6a7183acaffd1d02931314a51cdead9c8631cb3dfdf2ffca5601405a01146164e1f0043ced55431833c7550 SHA512 0336fadd44fd097e7d10111c18c59725293170f8b0d3779b2b710761c74065cffe7414c576b4df587ef5b1d7794217553a5562e5c665c5a37d660cf9e26bc08e
+DIST luit-20240102.tgz.asc 729 BLAKE2B d5b133c4cb12e9d17e38d48d0def4fc5533445412375511703334ddbcea3f9987a3043acd4071729e5d71fc7cfeb7c5c02ad7e0b6bb1309d60bc25d646b76997 SHA512 e4b285d147a216003537cd00dd481f4823336f7b8ca9357a561c8adb8bbfca8d584cf304683fe697d7d2713f795a94d973545a092d5d3252d904e5d22357a81e
diff --git a/x11-apps/luit/luit-20240102.ebuild b/x11-apps/luit/luit-20240102.ebuild
new file mode 100644
index 000000000000..9488fc4ce413
--- /dev/null
+++ b/x11-apps/luit/luit-20240102.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="Locale and ISO 2022 support for Unicode terminals"
+HOMEPAGE="https://invisible-island.net/luit/"
+SRC_URI="https://invisible-mirror.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+DEPEND="
+ sys-libs/zlib
+ virtual/libiconv
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-apps/groff
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+src_configure() {
+ econf --disable-fontenc --enable-iconv
+}