summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-09-22 05:48:08 +0000
committerYixun Lan <dlan@gentoo.org>2023-09-22 05:48:16 +0000
commitdf41bc57d1e5dc4f2db30b300a1901327c36bff6 (patch)
tree0115d857d21d386b0598b174e64665d36c80bd6d
parentdev-libs/libgpiod: add 1.6.4 (diff)
downloadgentoo-df41bc57d1e5dc4f2db30b300a1901327c36bff6.tar.gz
gentoo-df41bc57d1e5dc4f2db30b300a1901327c36bff6.tar.bz2
gentoo-df41bc57d1e5dc4f2db30b300a1901327c36bff6.zip
dev-libs/libgpiod: add 2.0.2
todo: profiling, examples, rust-binding Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-libs/libgpiod/Manifest1
-rw-r--r--dev-libs/libgpiod/libgpiod-2.0.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libgpiod/Manifest b/dev-libs/libgpiod/Manifest
index 744ed391b1e3..87f31efdb3c4 100644
--- a/dev-libs/libgpiod/Manifest
+++ b/dev-libs/libgpiod/Manifest
@@ -1,2 +1,3 @@
DIST libgpiod-1.6.3.tar.xz 326068 BLAKE2B eda5409f2db3914ede92690589643211eca3002f8dc53a7c48213602f28158084c8eb8061319923f7a51c7d91650ff58b81b059323b5b9133a28b0bb04f6904d SHA512 f7e48662d02904f3f25976d61aa2cf4af0b8a52f65f184f23dfb6916bde9b86634b211f2696d3459a4f902ba5a79621b2fc47d18d487fd7a159018fe8933e370
DIST libgpiod-1.6.4.tar.xz 334552 BLAKE2B 3bf52dab263638967e0f59c858e22f3d8ec1c9565ba1edd665dff580a883fbc6aa49a944e6df4da8fca9c2df873e222ed4e055c9792ee27d4562b3c2d0c65b79 SHA512 23ea27147039ae34505263dbfbb3ca9985fc671d26e489ccaf150543d4e853f709393f46a8a5a1e682fa91378163bd2db6c689159ef73c3a8d1eeea422eacda0
+DIST libgpiod-2.0.2.tar.xz 408672 BLAKE2B aa63edc12ad4a473dcf753160d4c6d8b1ebe7b99afe6fa60b968975e10f943d57bd75ff039732d3c26be6ff5e044ce8e0638ea3e21625e4d298b6005bf442a3a SHA512 3e92fe8b52da20abc89dd857a10f0e7fef77663a7a6cbcd7471f49843d54e9a053fa150a3f5b200f220a1a40c2ded010c271deba796fbc0775010d980a7083f1
diff --git a/dev-libs/libgpiod/libgpiod-2.0.2.ebuild b/dev-libs/libgpiod/libgpiod-2.0.2.ebuild
new file mode 100644
index 000000000000..94df11b5ec4b
--- /dev/null
+++ b/dev-libs/libgpiod/libgpiod-2.0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+# Reflects the ABI of libgpiod.so
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="+tools cxx python test"
+RESTRICT="!test? ( test )"
+
+# --enable-tests enable libgpiod tests [default=no]
+# --enable-bindings-cxx enable C++ bindings [default=no]
+# --enable-bindings-python
+# --enable-bindings-rust
+DEPEND="
+ test? (
+ >=dev-libs/glib-2.50
+ >=sys-apps/kmod-18
+ >=sys-apps/util-linux-2.33.1
+ >=virtual/libudev-215
+ )
+"
+
+pkg_setup() {
+ CONFIG_CHECK="~GPIO_CDEV_V1"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable tools)
+ $(use_enable cxx bindings-cxx)
+ $(use_enable test tests)
+ $(use_enable python bindings-python)
+ --enable-examples
+ --disable-profiling
+ --disable-bindings-rust
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+ find "${D}" -name "*.a" -delete || die
+}