summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-03-01 16:20:58 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-03-01 16:20:58 +0100
commitdf47d5f58ec12b03055b520b98d921b1e202618e (patch)
tree8313eb97fd683b3ba3c04e832faf4fac5e034468
parentx11-plugins/wmdots: fix build with -fno-common (diff)
downloadgentoo-df47d5f5.tar.gz
gentoo-df47d5f5.tar.bz2
gentoo-df47d5f5.zip
x11-plugins/wmSpaceWeather: fix build with -fno-common
Closes: https://bugs.gentoo.org/707600 Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gcc-10.patch23
-rw-r--r--x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild3
2 files changed, 25 insertions, 1 deletions
diff --git a/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gcc-10.patch b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gcc-10.patch
new file mode 100644
index 000000000000..f95e7e5ccbe0
--- /dev/null
+++ b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gcc-10.patch
@@ -0,0 +1,23 @@
+diff -Naur wmspaceweather-1.04.orig.orig/wmgeneral/wmgeneral.h wmspaceweather-1.04.orig/wmgeneral/wmgeneral.h
+--- wmspaceweather-1.04.orig.orig/wmgeneral/wmgeneral.h 1999-04-11 07:35:53.000000000 +0200
++++ wmspaceweather-1.04.orig/wmgeneral/wmgeneral.h 2020-03-01 16:13:29.843346352 +0100
+@@ -28,7 +28,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
+diff -Naur wmspaceweather-1.04.orig.orig/wmSpaceWeather/wmSpaceWeather.c wmspaceweather-1.04.orig/wmSpaceWeather/wmSpaceWeather.c
+--- wmspaceweather-1.04.orig.orig/wmSpaceWeather/wmSpaceWeather.c 1999-04-11 07:35:53.000000000 +0200
++++ wmspaceweather-1.04.orig/wmSpaceWeather/wmSpaceWeather.c 2020-03-01 16:13:38.172348429 +0100
+@@ -91,6 +91,7 @@
+ char URL[1024];
+ int ForceUpdate2;
+
++Display *display;
+
+ void ParseCMDLine(int argc, char *argv[]);
+ void pressEvent(XButtonEvent *xev);
diff --git a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
index 568c3f7524fb..9bd5996db7f1 100644
--- a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
+++ b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -36,6 +36,7 @@ S="${WORKDIR}/${MY_P_ORIG/_/-}/${PN}"
src_unpack() {
unpack ${MY_P_ORIG}.tar.gz
epatch "${DISTDIR}"/${MY_P_PATCH}.gz
+ epatch "${FILESDIR}"/${P}-gcc-10.patch
# need to apply patches from Debian first, do NOT change the order
cd "${S}" || die