summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-20 19:48:42 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-20 20:17:08 +0100
commitdf4dbec65f605fa60c6a627c2ea7c5bee2300c25 (patch)
tree80bdc0f3b294e1b39680058394f4c59465a575f4
parentdev-python/rpds-py: Bump to 0.13.1 (diff)
downloadgentoo-df4dbec65f605fa60c6a627c2ea7c5bee2300c25.tar.gz
gentoo-df4dbec65f605fa60c6a627c2ea7c5bee2300c25.tar.bz2
gentoo-df4dbec65f605fa60c6a627c2ea7c5bee2300c25.zip
dev-python/txtorcon: Bump to 23.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/txtorcon/Manifest1
-rw-r--r--dev-python/txtorcon/txtorcon-23.11.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/txtorcon/Manifest b/dev-python/txtorcon/Manifest
index 021c0fbb9e57..6907e7a34aa5 100644
--- a/dev-python/txtorcon/Manifest
+++ b/dev-python/txtorcon/Manifest
@@ -1 +1,2 @@
+DIST txtorcon-23.11.0.gh.tar.gz 395211 BLAKE2B 156c1c1d7e1d88939051ea19f4cd955e3a329dd1a550ea1a35d6c984db66d9b8e7fff35b2aa5caa12589273b46c1ce65d802fe89ce2a57443e0b5ce592247ee0 SHA512 815aecd8b6f3d12be1f903ba4dbb037e5f5920d925ca06c9f92a040d8258c4c1182ae5fca0be26fd2adb529c1726ad9ee080ddcada56e3e8b9922f7295731df3
DIST txtorcon-23.5.0.gh.tar.gz 394188 BLAKE2B ee63d2815a9b697aa37d27697ef6085dc91e750ba0cad854c8610eed7afcfec9b50cf5aead24f75676e2b0ee39167c50fbebc43a51911a3ebe17eb784b18d31e SHA512 33610c043084273f5dc06b797fff11bb0fccaae14229dbd07286e13e40ebc199594f6e52c64b87e4060e37bcb44bd90ccf7ff7217d923fdb33a581fb95144d56
diff --git a/dev-python/txtorcon/txtorcon-23.11.0.ebuild b/dev-python/txtorcon/txtorcon-23.11.0.ebuild
new file mode 100644
index 000000000000..0d31f2388f06
--- /dev/null
+++ b/dev-python/txtorcon/txtorcon-23.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Twisted-based Tor controller client, with state-tracking abstractions"
+HOMEPAGE="
+ https://txtorcon.readthedocs.org/
+ https://github.com/meejah/txtorcon/
+ https://pypi.org/project/txtorcon/
+"
+SRC_URI="
+ https://github.com/meejah/txtorcon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/automat[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/twisted[ssl,${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ sys-process/lsof
+ )
+"
+
+distutils_enable_tests pytest