summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-04 18:03:57 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-05-05 20:56:04 +0200
commitdf67b9b484d970df381b7bc395a0e9a337d20581 (patch)
tree4a3341f032b94833854ea3394e88693adef0ef1e
parentwww-client/chromium: remove unused patch (diff)
downloadgentoo-df67b9b484d970df381b7bc395a0e9a337d20581.tar.gz
gentoo-df67b9b484d970df381b7bc395a0e9a337d20581.tar.bz2
gentoo-df67b9b484d970df381b7bc395a0e9a337d20581.zip
net-misc/connman-json-client: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild b/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild
new file mode 100644
index 000000000000..c5fed0b76125
--- /dev/null
+++ b/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools vcs-snapshot
+COMMIT="3c34b2ee62d2e188090d20e7ed2fd94bab9c47f2"
+
+DESCRIPTION="An ncurses UI for connman"
+HOMEPAGE="https://github.com/eurogiciel-oss/connman-json-client"
+SRC_URI="https://github.com/eurogiciel-oss/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/json-c:0=
+ >=sys-apps/dbus-1.4
+ sys-libs/ncurses:0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/cjc-fix-for-json-0.14.patch )
+
+src_prepare() {
+ sed -i -e '/^AM_CFLAGS/ s/ -Werror$//' Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ dobin connman_ncurses
+}