summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-29 06:48:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-29 06:50:52 +0100
commitdf7525f95b18ce4acfd8526df6e27f7a66aeb280 (patch)
tree5355a037c2efae4cd2c270c3b6bf6571cb6e3090
parentdev-python/aiohttp: Bump to 3.9.2 (diff)
downloadgentoo-df7525f95b18ce4acfd8526df6e27f7a66aeb280.tar.gz
gentoo-df7525f95b18ce4acfd8526df6e27f7a66aeb280.tar.bz2
gentoo-df7525f95b18ce4acfd8526df6e27f7a66aeb280.zip
dev-python/pytz: Bump to 2023.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytz/Manifest1
-rw-r--r--dev-python/pytz/pytz-2023.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index d09ead4326bc..51503712917b 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -1 +1,2 @@
DIST pytz-2023.3.post1.tar.gz 316899 BLAKE2B 3274e11c38b34eae42089cacf92e537f1376fa721294ea2da3a68fe3491e7e95d1c88cb4687d1e83965be4730504373c72960f5dc5e9b6a8a339e541476515f4 SHA512 c2f1bd52e42c7d1014b8aebf3544b865eb5ae5e17146253406def72785af14bcfe34b9db6b71ca91a3c988c496fbe93e5d1731bee66349463c992be619d21f2c
+DIST pytz-2023.4.tar.gz 319467 BLAKE2B 59c27d2b6b748808edf81649ba08ca9230e9a14936f2307918c57fa69e5ff379d2dee1288252112bd718483e84ad1fafb551da222d26b01c4dd7c86424533993 SHA512 dc132f305d6f8f491a004f65fa823aa76713d324592ef474abfd5c0aafdf722d22386cf7f9140b2868f48e1309a64385204a129c0ed6c0bf8356844b92f13bb0
diff --git a/dev-python/pytz/pytz-2023.4.ebuild b/dev-python/pytz/pytz-2023.4.ebuild
new file mode 100644
index 000000000000..dc593325174c
--- /dev/null
+++ b/dev-python/pytz/pytz-2023.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="
+ https://pythonhosted.org/pytz/
+ https://github.com/stub42/pytz/
+ https://pypi.org/project/pytz/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ >=sys-libs/timezone-data-2023b
+ sys-libs/glibc[vanilla]
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unbundle timezone-data
+ rm -r pytz/zoneinfo || die
+ # remove hardcoded list of all timezones but leave subjective set
+ # of "common timezones"
+ sed -i -e '/^_all_timezones_unchecked/,/^all_timezones_set/d' pytz/__init__.py || die
+ eapply "${FILESDIR}"/pytz-2023.2-system-tzinfo.patch
+}
+
+python_test() {
+ "${EPYTHON}" pytz/tests/test_tzinfo.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}