summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-06 10:22:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-06 11:00:36 +0100
commitdf926459a10906cf16efd037b09cda2eb5638ae0 (patch)
tree5daa437e73e0675334fadfeebb604ad10c78ae04
parentdev-python/jaraco-envs: Bump to 2.1.0 (diff)
downloadgentoo-df926459a10906cf16efd037b09cda2eb5638ae0.tar.gz
gentoo-df926459a10906cf16efd037b09cda2eb5638ae0.tar.bz2
gentoo-df926459a10906cf16efd037b09cda2eb5638ae0.zip
dev-python/httpretty: Bump to 1.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/httpretty/Manifest1
-rw-r--r--dev-python/httpretty/httpretty-1.0.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/httpretty/Manifest b/dev-python/httpretty/Manifest
index 09b1d35e84c1..b76e6e579dc4 100644
--- a/dev-python/httpretty/Manifest
+++ b/dev-python/httpretty/Manifest
@@ -1 +1,2 @@
DIST httpretty-1.0.3.tar.gz 411707 BLAKE2B b2211457c937e19f8110bc28446a2b78a8042a742341c0492589def7447e819f051d301e9d254260778f349302ccf6fc163a9f2280a55af925ae353752450320 SHA512 a6349257376c12198d0bf7923245c34f6b8a0889946ba0c2551fd3379a8d9a8e4610de81c66f945656c1879ad3fb1485f2f4148634fcc4e156b9f0a59f7dd758
+DIST httpretty-1.0.5.tar.gz 414946 BLAKE2B 8bbaac3d53fbf5744f7bf8ef952bd9305112934af24809a233ef0446886e09b7d2a897e69aded12d9e715580305d729609365b0be55f8d324cc48e6aa0699d75 SHA512 2e5f4834848ab1a0b84230f000afb0409b30b3cc1769d36ad61f712f56abc8d6076e7507598f791fe343ce282cf9e26939add71ef794ead2836badfc2321d6bb
diff --git a/dev-python/httpretty/httpretty-1.0.5.ebuild b/dev-python/httpretty/httpretty-1.0.5.ebuild
new file mode 100644
index 000000000000..0b217df07e41
--- /dev/null
+++ b/dev-python/httpretty/httpretty-1.0.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]"
+# redis skipped as it requires a redis server running
+DEPEND="
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.2[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+ dev-python/sure[${PYTHON_USEDEP}]
+ >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
+)"
+
+python_prepare_all() {
+ # remove useless deps
+ sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
+ # tests requiring network access
+ rm tests/functional/test_passthrough.py || die
+ # requires running redis server
+ # it is skipped correctly but it causes unnecessary dep on redis-py
+ rm tests/functional/bugfixes/test_redis.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests || die "Tests fail with ${EPYTHON}"
+}