summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-12-15 14:36:58 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-12-15 14:37:24 +0100
commitdfa4cf3880629d05592b347210a6d251e037646f (patch)
tree738ccd0969cb44336cf60fbf3df82dbb6c309ed5
parentsys-auth/passwdqc: Stabilize 2.0.3-r1 x86, #919937 (diff)
downloadgentoo-dfa4cf38.tar.gz
gentoo-dfa4cf38.tar.bz2
gentoo-dfa4cf38.zip
www-apps/webmcp: fix c99
Closes: https://bugs.gentoo.org/919229 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--www-apps/webmcp/files/webmcp-2.1.0-c99.patch20
-rw-r--r--www-apps/webmcp/webmcp-2.1.0-r1.ebuild (renamed from www-apps/webmcp/webmcp-2.1.0.ebuild)7
2 files changed, 25 insertions, 2 deletions
diff --git a/www-apps/webmcp/files/webmcp-2.1.0-c99.patch b/www-apps/webmcp/files/webmcp-2.1.0-c99.patch
new file mode 100644
index 000000000000..ac27ebb43295
--- /dev/null
+++ b/www-apps/webmcp/files/webmcp-2.1.0-c99.patch
@@ -0,0 +1,20 @@
+--- a/libraries/extos/extos.c 2023-12-15 10:12:53.396506457 +0100
++++ b/libraries/extos/extos.c 2023-12-15 14:32:20.464092779 +0100
+@@ -262,7 +262,7 @@
+ if (result != 1) goto extos_pfilter_error_fd_remapping;
+ do result = dup(pipe_err[1]); while (result < 0 && errno == EINTR);
+ if (result != 2) goto extos_pfilter_error_fd_remapping;
+- execvp(filename, args);
++ execvp(filename, (char * const*)args);
+ status_buf[0] = errno;
+ do result = write(pipe_status[1], status_buf, 1); while (result < 0 && errno == EINTR);
+ _exit(0);
+@@ -287,7 +287,7 @@
+ lua_settop(L, 0);
+ lua_newtable(L); // 1
+ while (1) {
+- readdir_r(dir, &entry_buffer, &entry);
++ entry = readdir(dir);
+ if (!entry) break;
+ // Linux doesn't have d_namlen
+ //lua_pushlstring(L, entry->d_name, entry->d_namlen);
diff --git a/www-apps/webmcp/webmcp-2.1.0.ebuild b/www-apps/webmcp/webmcp-2.1.0-r1.ebuild
index 832a99224e46..a44301ee98d0 100644
--- a/www-apps/webmcp/webmcp-2.1.0.ebuild
+++ b/www-apps/webmcp/webmcp-2.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,7 +26,10 @@ REQUIRED_USE="${LUA_REQUIRED_USE}"
S="${WORKDIR}"/${MY_P}
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-c99.patch
+)
src_compile() {
emake CC="$(tc-getCC)" \