summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-01 20:41:08 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-01 21:30:38 +0300
commitdfbb6a8628a936ea6f8c2f6062bcf4e770db380b (patch)
treea46fa4ee7a8b923f35a29c81ae00b1ce7c51a33f
parentnet-misc/openssh-8.7_p1-r1: Revbump, add X509 patch (diff)
downloadgentoo-dfbb6a86.tar.gz
gentoo-dfbb6a86.tar.bz2
gentoo-dfbb6a86.zip
dev-python/pytest: add 6.2.5, enable py3.10 tests
Closes: https://bugs.gentoo.org/811309 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-6.2.5.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 71207e93192e..37f3f97d8410 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -2,3 +2,4 @@ DIST pytest-4.6.11.tar.gz 952305 BLAKE2B af07adf5e8fc614b1fdb7b5673fb9c557ff0dd3
DIST pytest-5.4.3.tar.gz 1022353 BLAKE2B 70d4f23cbbfc4c4ce63c512ee0a01556973761a6d3ebb71a6d9ed4fb4a4a21531e1b151ed0e4c5e56e5dd3243a1a272441f17c4c2c4e3b0b19c24654b74e8e52 SHA512 0a07d4f4f791969c6f21961a0ba0f8c6670e5870c6cc1cebf93766587bb9cb3e10db8e57f0bd33dd22b275f3aad7aa674949f124ac80e0ccca64e35be4beee4e
DIST pytest-6.1.2.tar.gz 1084943 BLAKE2B cbdf29c54118b5daf699f11fb674d37d5972a163a7a53f42f6ddf9224e2d8d9e84b9a88106d5a77e70f470ccbffb15c2cf9a939be69bc0a2cab1fc4c76054562 SHA512 6335e994c5273881c8d1c334fe6bfa9cd0a3e5c251f3d6a9332f7f7c1427e6560ff48d8f235b307ea5eb53491072daf30c41f566bb67b304354fd88d286c61b1
DIST pytest-6.2.4.tar.gz 1118084 BLAKE2B 611db50e7432dfb6f8d212621a3803871fd8f6c05ec3cdefeb3958d0886f754326fc358a9a67bdb3f516388aab901b169c951471bf304adfb78fe457dc59d6c5 SHA512 43adc9a78e16a05f07e689e4557b63f2e0f4de5a1cdea6f24272b6a658a6b0a18721713cf46b5102cf2726ddbc4ffe131c39e652bd2511d285f40cbfcccc2289
+DIST pytest-6.2.5.tar.gz 1118720 BLAKE2B 9dfc87279617be58353566009325f929e6fa53d54fd4c665a75f3b359ab5415972d745a680eb85ab21ca9eaec84450bc1decd50566b0ccdf90d7551f3d03ee70 SHA512 7624563a9d967da4cbf82cfff90bae8c0cca07b32e291dc7c5efa787725ed1a255edd066bf0d5fbd89b8cbed8cf5b619fe7c7017f44a7f8a014e3310c06bdbf9
diff --git a/dev-python/pytest/pytest-6.2.5.ebuild b/dev-python/pytest/pytest-6.2.5.ebuild
new file mode 100644
index 000000000000..4cace9f6b7e0
--- /dev/null
+++ b/dev-python/pytest/pytest-6.2.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="https://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3)
+ dev-python/iniconfig[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ >=dev-python/py-1.8.2[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+src_test() {
+ # workaround new readline defaults
+ echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
+ local -x INPUTRC="${T}"/inputrc
+ distutils-r1_src_test
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+
+ "${EPYTHON}" -m pytest -vv --lsof -rfsxX -p no:pkgcore -p no:flaky ||
+ die "Tests failed with ${EPYTHON}"
+}