summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 09:56:39 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 09:58:57 +0100
commitdfbc7e0999a86a9cfbd17577d22290cd4287e606 (patch)
tree4e1581cf4929fc4a91661bb446df77e4dce20aab
parentsys-libs/llvm-libunwind: Delay llvm.org_set_globals after vars (diff)
downloadgentoo-dfbc7e0999a86a9cfbd17577d22290cd4287e606.tar.gz
gentoo-dfbc7e0999a86a9cfbd17577d22290cd4287e606.tar.bz2
gentoo-dfbc7e0999a86a9cfbd17577d22290cd4287e606.zip
sys-libs/libcxxabi: Delay llvm.org_set_globals after vars
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild12
-rw-r--r--sys-libs/libcxxabi/libcxxabi-12.0.0.9999.ebuild12
2 files changed, 14 insertions, 10 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild
index 4b304417a9c3..c1992223348b 100644
--- a/sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild
@@ -9,10 +9,6 @@ inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="Low level support for a standard C++ library"
HOMEPAGE="https://libcxxabi.llvm.org/"
-# libcxx is needed uncondtionally for the headers
-LLVM_COMPONENTS=( libcxx{abi,} )
-LLVM_TEST_COMPONENTS=( llvm/cmake )
-llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
@@ -32,7 +28,13 @@ DEPEND="${RDEPEND}
>=sys-devel/llvm-6"
BDEPEND="
test? ( >=sys-devel/clang-3.9.0
- $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
+ $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
+ )"
+
+# libcxx is needed uncondtionally for the headers
+LLVM_COMPONENTS=( libcxx{abi,} )
+LLVM_TEST_COMPONENTS=( llvm/cmake )
+llvm.org_set_globals
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
diff --git a/sys-libs/libcxxabi/libcxxabi-12.0.0.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-12.0.0.9999.ebuild
index 4b304417a9c3..c1992223348b 100644
--- a/sys-libs/libcxxabi/libcxxabi-12.0.0.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-12.0.0.9999.ebuild
@@ -9,10 +9,6 @@ inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="Low level support for a standard C++ library"
HOMEPAGE="https://libcxxabi.llvm.org/"
-# libcxx is needed uncondtionally for the headers
-LLVM_COMPONENTS=( libcxx{abi,} )
-LLVM_TEST_COMPONENTS=( llvm/cmake )
-llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
@@ -32,7 +28,13 @@ DEPEND="${RDEPEND}
>=sys-devel/llvm-6"
BDEPEND="
test? ( >=sys-devel/clang-3.9.0
- $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
+ $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
+ )"
+
+# libcxx is needed uncondtionally for the headers
+LLVM_COMPONENTS=( libcxx{abi,} )
+LLVM_TEST_COMPONENTS=( llvm/cmake )
+llvm.org_set_globals
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"