summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-11-24 07:03:37 +0100
committerJeroen Roovers <jer@gentoo.org>2015-11-24 07:03:37 +0100
commitdfdbf77126635fb80d28ccc9987851b4dbe19aae (patch)
tree24494d5e7d3e08463fc9c845734037ce4feb0a88
parentapp-admin/salt: update the tests in 2015.5.7 (diff)
downloadgentoo-dfdbf771.tar.gz
gentoo-dfdbf771.tar.bz2
gentoo-dfdbf771.zip
net-analyzer/nmap: Version bump (bug #566568 by Anton Bolshakov).
Package-Manager: portage-2.2.25
-rw-r--r--net-analyzer/nmap/Manifest1
-rw-r--r--net-analyzer/nmap/nmap-7.00.ebuild155
2 files changed, 156 insertions, 0 deletions
diff --git a/net-analyzer/nmap/Manifest b/net-analyzer/nmap/Manifest
index a1b2c8fc11cc..c86a189baa55 100644
--- a/net-analyzer/nmap/Manifest
+++ b/net-analyzer/nmap/Manifest
@@ -1,4 +1,5 @@
DIST nmap-6.47.tar.bz2 7878122 SHA256 8fa11e9e203ce2d81a207db5ca4f110a525f6c01c1dd0018325a7112a51aa591 SHA512 f98b92a26f4e912fe15c36a21dfff7bfb9f11c2410f4035330100648fbad7f808ef9e069c63704bbb50199272ae65ea81555de6c97eb8ee152114f44ed5a9296 WHIRLPOOL 4f92f0aeaaa03a94dc27080b5f0c2396325f282b7a781d163d1e05a71117896c4581154b58383f136eed1fcf2cce8f1b94e3344f3fc5d4955cf1f4cfc1417573
DIST nmap-6.49BETA2.tar.bz2 8810504 SHA256 e2f2aaa872fec288b927ceb59500edba198d8767adbe3a83a939e7921b224b79 SHA512 f21f0e6677c5936d49aab0a7de083b1309c49a91289691636d5ad1dfa052426d657b0a1df30519fcda712007abee0a4cd1bf89963b2e6758b11d2c18d96d637e WHIRLPOOL 1fd1b57f6b95526fabfd30cdee3064b6626735b51fcd23b8b3e91609e1b7fc126f0fd97fc2f2d478f8035ae148830afb5ab5c6bc454ac518a3023b566e1c100d
DIST nmap-6.49BETA6.tar.bz2 8904750 SHA256 9c548ee0e3f0db73c4b5f8434c0bc7c99188333562c4bc4e04fb721533ff1637 SHA512 ca8bfc2dfa7f9e892e8014eefaf8aa97cefcf6f05946177e07b4dcf8e82cb1c1c2db2cf3bacd2fef1e5c4c93d7b73607e1367880e01a26f3a32c77fed09ead28 WHIRLPOOL 82e6c89b71405372b443600ab9da49fde2c2af63ab9d1990b5c6011ac52426ed28206175ae715c8e31f3d4c2acbe0536be535b878a0837578e41aff5c2c90a2c
+DIST nmap-7.00.tar.bz2 8918906 SHA256 9f442301c615c608a385831c3505cdfed9b0795cd100f1a258b04509802802ae SHA512 f8b4368de5956698e76a2a102102feb4bd00338cf983bfbf7bcd8c941288bb4a02c45469724e8a1daed87f41536a3f16a68fc604171fe23093575ac631637351 WHIRLPOOL f769a28b32c24874eb3d4fc3100ae1e7f271bc54837f992505754f31104de18a12116350b3fbf3402719d7e84110054e8f4fb7ea18ffa3b45f17fab8554998eb
DIST nmap-logo-64.png 3289 SHA256 4c72ff1eeffeeaa1039b251d9f2d675936e65db686fe3b57a35c2183ce67a8aa SHA512 fb102d12aaeebc8a97543ecd653a3606e86996ad679bc26d6e6e274ad05ec3e9f92521289d1a24153c521b699e8c0cfa65d8856bb49af53ee4837268bbc6b5d3 WHIRLPOOL 6093aadcb9880587e17d39d45fcbe57bb62777f220655e6ed5b5f900ce49cb8c5a53e24d7db0de6f8909eb0f8981f7565e6ae9b9bf9283a4ccccb0526eab5313
diff --git a/net-analyzer/nmap/nmap-7.00.ebuild b/net-analyzer/nmap/nmap-7.00.ebuild
new file mode 100644
index 000000000000..0022291860af
--- /dev/null
+++ b/net-analyzer/nmap/nmap-7.00.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,xml"
+inherit eutils flag-o-matic python-single-r1 toolchain-funcs
+
+MY_P=${P/_beta/BETA}
+
+DESCRIPTION="A utility for network discovery and security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="
+ http://nmap.org/dist/${MY_P}.tar.bz2
+ https://dev.gentoo.org/~jer/nmap-logo-64.png
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="ipv6 libressl +nse system-lua ncat ndiff nls nmap-update nping ssl zenmap"
+NMAP_LINGUAS=( de fr hi hr it ja pl pt_BR ru zh )
+IUSE+=" ${NMAP_LINGUAS[@]/#/linguas_}"
+
+REQUIRED_USE="
+ system-lua? ( nse )
+ ndiff? ( ${PYTHON_REQUIRED_USE} )
+ zenmap? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ dev-libs/liblinear:=
+ dev-libs/libpcre
+ net-libs/libpcap[ipv6?]
+ zenmap? (
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ system-lua? ( >=dev-lang/lua-5.2[deprecated] )
+ ndiff? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )
+ nmap-update? ( dev-libs/apr dev-vcs/subversion )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use ndiff || use zenmap; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_unpack() {
+ # prevent unpacking the logo
+ unpack ${MY_P}.tar.bz2
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-4.75-nolua.patch \
+ "${FILESDIR}"/${PN}-5.10_beta1-string.patch \
+ "${FILESDIR}"/${PN}-5.21-python.patch \
+ "${FILESDIR}"/${PN}-6.46-uninstaller.patch \
+ "${FILESDIR}"/${PN}-6.47-no-libnl.patch \
+ "${FILESDIR}"/${PN}-6.49-no-FORTIFY_SOURCE.patch \
+ "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
+
+ if use nls; then
+ local lingua=''
+ for lingua in ${NMAP_LINGUAS[@]}; do
+ if ! use linguas_${lingua}; then
+ rm -r zenmap/share/zenmap/locale/${lingua} || die
+ rm zenmap/share/zenmap/locale/${lingua}.po || die
+ fi
+ done
+ else
+ # configure/make ignores --disable-nls
+ for lingua in ${NMAP_LINGUAS[@]}; do
+ rm -r zenmap/share/zenmap/locale/${lingua} || die
+ rm zenmap/share/zenmap/locale/${lingua}.po || die
+ done
+ fi
+
+ sed -i \
+ -e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
+ Makefile.in || die
+
+ # Fix desktop files wrt bug #432714
+ sed -i \
+ -e '/^Encoding/d' \
+ -e 's|^Categories=.*|Categories=Network;System;Security;|g' \
+ zenmap/install_scripts/unix/zenmap-root.desktop \
+ zenmap/install_scripts/unix/zenmap.desktop || die
+
+ epatch_user
+}
+
+src_configure() {
+ # The bundled libdnet is incompatible with the version available in the
+ # tree, so we cannot use the system library here.
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with zenmap) \
+ $(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
+ $(use_with ncat) \
+ $(use_with ndiff) \
+ $(use_with nmap-update) \
+ $(use_with nping) \
+ $(use_with ssl openssl) \
+ --with-libdnet=included \
+ --with-pcre=/usr
+ # --with-liblinear=/usr \
+ # Commented because configure does weird things, while autodetection works
+}
+
+src_compile() {
+ emake \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ LC_ALL=C emake -j1 \
+ DESTDIR="${D}" \
+ STRIP=: \
+ nmapdatadir="${EPREFIX}"/usr/share/nmap \
+ install
+ if use nmap-update;then
+ LC_ALL=C emake -j1 \
+ -C nmap-update \
+ DESTDIR="${D}" \
+ STRIP=: \
+ nmapdatadir="${EPREFIX}"/usr/share/nmap \
+ install
+ fi
+
+ dodoc CHANGELOG HACKING docs/README docs/*.txt
+
+ if use zenmap; then
+ doicon "${DISTDIR}/nmap-logo-64.png"
+ python_optimize
+ fi
+}