summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-03-11 09:14:47 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-03-11 13:03:40 +0200
commitdfe559ee0d581d16966d8638382b57e2a560ca46 (patch)
treeaeff95a6810442eedeead503739ae1610f12b5b4
parentwww-apps/drupal: add 9.5.2 (diff)
downloadgentoo-dfe559ee0d581d16966d8638382b57e2a560ca46.tar.gz
gentoo-dfe559ee0d581d16966d8638382b57e2a560ca46.tar.bz2
gentoo-dfe559ee0d581d16966d8638382b57e2a560ca46.zip
www-apps/drupal: add 10.0.2
drupal 10.0.2 is the latest security release from 10.0 branch from 2023-01-18. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-10.0.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 328327bc7064..59f9fe05e718 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,4 @@
+DIST drupal-10.0.2.tar.gz 17411661 BLAKE2B c7a9a98f1e8c120486c1a6bd17986b3e99c1e51113969413eb557f657fa3415f65b819a70d08be7c543b6609cba2881b18fa69ce77fe8b3764d9a4a12f569e04 SHA512 19f3f2459c8d2d54647f43db614cd493cb6f068d107678bb6c36823407fe815db71b7919fe755f40fb10c3697afb07e20c93fe47098de88f9248f18cf901da80
DIST drupal-7.89.tar.gz 3361853 BLAKE2B 5388c6c9ded2ce31caee1bea23976e2c2d53116f6e564fd47f4035e9815e28759bf4e56964754d01c165ae7c384527c3c1845ef6b9c3b1b029b9eca3c56e7442 SHA512 3f1f50b09bfd77afaad368c21a00d2fb52a4a3853bf288525a805fab992083ffb241c2b3bfef8db3b4351310b0a0d5d27470fa7adc191c687809f48464f18f0b
DIST drupal-7.91.tar.gz 3369203 BLAKE2B 202b3cbcbb25bb92f056c15cb8f697038caacdd62497de02b7e0036dc5dd5ac6e9b12c67620b753a5fbe8440e5883aec3061a626d753d9cca4f48b6d6358b3fc SHA512 da38735563cf5a76f432907b61943339b9d7f218e5abe5b5187138a470b545db14e23bb708fa53adc0853f9b46b34242e7eae3222e53b62fdafef29b2b476169
DIST drupal-9.1.15.tar.gz 18580086 BLAKE2B 500602e498de55d2163c53d2cb04effbdab24d343a2f04262275c6500d9329b12760dee846513efbddc37916973dc9ad4bf0f6f882b1b57b0ca97b40afb369be SHA512 1fd8cbdbf0de00ed6d85a004f61fb3897cfcbc1f71d1d72373c8acf108f21774f3a91138901d9a3d0043f6b65b29ae7f953dfce1428a96a4fe529aac907141c0
diff --git a/www-apps/drupal/drupal-10.0.2.ebuild b/www-apps/drupal/drupal-10.0.2.ebuild
new file mode 100644
index 000000000000..6a27404d4a84
--- /dev/null
+++ b/www-apps/drupal/drupal-10.0.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+# upstream supports php 8.1+, but dev-php/pecl-uploadprogress does not have 8.2
+# limit php to 8.1 for now
+RDEPEND="
+ dev-lang/php:8.1[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress[php_targets_php8-1] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.md core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt \
+ core/USAGE.txt "
+
+ dodoc ${docs}
+ rm ${docs} core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-10 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}