summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:33:18 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:33:18 +0200
commitdfe96ba96c5e3add435167c60725cca69c068cfe (patch)
tree4ee498de6795132b9daa81eeed61ee4038e8f77a
parentdev-python/responses: add 0.19.0 (diff)
downloadgentoo-dfe96ba96c5e3add435167c60725cca69c068cfe.tar.gz
gentoo-dfe96ba96c5e3add435167c60725cca69c068cfe.tar.bz2
gentoo-dfe96ba96c5e3add435167c60725cca69c068cfe.zip
dev-python/zope-testing: add 4.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/zope-testing/Manifest1
-rw-r--r--dev-python/zope-testing/zope-testing-4.10.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/zope-testing/Manifest b/dev-python/zope-testing/Manifest
index 092affe13b43..8c42f0d8f341 100644
--- a/dev-python/zope-testing/Manifest
+++ b/dev-python/zope-testing/Manifest
@@ -1 +1,2 @@
+DIST zope.testing-4.10.tar.gz 45359 BLAKE2B 477d28a7d1a76c0a5111f16859d9e3b9b9ac9cc953b0e2c7dd9ba0a39b498d71442d1b5aaf485455c919ad618efb1f9f9b8e1587fd4905c4a823b04ef09ef8b2 SHA512 35fd5114b6de3cb47336185feb8bf8f444b53ef2c32f165e57756a017ec9caba9a29f2ec01844ebcf156fff1c2b7424b3ac126b3e8d4daefe73e1a640d21589a
DIST zope.testing-4.9.tar.gz 62294 BLAKE2B 34b2fc10e7220d88451b655d0e43f513d004779c496c824fa3e58b17c883a401f4707d5dbe7a547f1f97fe7db73b25cdf16997f2733b832ceabc37f1d5265397 SHA512 04b660aa93e120ae7e57bf637d99302d26912800ea3995a24c6d252ee4bd8e06fd8d4a24d980f591846d9bca93523373a92528ef492ff4d6990887ab6cf527d0
diff --git a/dev-python/zope-testing/zope-testing-4.10.ebuild b/dev-python/zope-testing/zope-testing-4.10.ebuild
new file mode 100644
index 000000000000..145ffda764aa
--- /dev/null
+++ b/dev-python/zope-testing/zope-testing-4.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope testing helpers"
+HOMEPAGE="https://pypi.org/project/zope.testing/
+ https://github.com/zopefoundation/zope.testing"
+SRC_URI="mirror://pypi/${P::1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}