summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-09-22 15:21:08 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-09-22 15:21:14 -0700
commitdfeab0091f1619910440f49648caeae50137789d (patch)
treef63a08ca316e62388547bb4dc74e08eb9078528d
parentmedia-sound/spotify: add missing dep on dev-libs/libayatana-appindicator (diff)
downloadgentoo-dfeab009.tar.gz
gentoo-dfeab009.tar.bz2
gentoo-dfeab009.zip
app-misc/asciinema: add 2.3.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-misc/asciinema/Manifest1
-rw-r--r--app-misc/asciinema/asciinema-2.3.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/asciinema/Manifest b/app-misc/asciinema/Manifest
index a3ac8e743a57..8cee78566763 100644
--- a/app-misc/asciinema/Manifest
+++ b/app-misc/asciinema/Manifest
@@ -1 +1,2 @@
DIST asciinema-2.2.0.gh.tar.gz 88566 BLAKE2B c96eac56714a4519d462bdf24f3fcc0ec367af94182e6710d4744113c5ac3ec9304fbda30f3489b84bc4b645e43ea44d633230128d79a576d4bcbe7dad528ba8 SHA512 bed0b6a3228b973dddb2f03d0b0e16af0afd6e1c4c8c1379999d49b22ed658fed325f902f462156745631f98b51675565b7ea0011512c95c8b0b3bb09552bddc
+DIST asciinema-2.3.0.gh.tar.gz 91464 BLAKE2B ff2f38715a9c69ec15ad8dfdfa282a49c32075e6be43ce2f568d188678d6fee1351f36f8dd2a272052f43087cf222e2b14d37ed26a42ba11396074523391efc5 SHA512 09951d96938faaf71a5b71f5a514ffacb32be224883691aec7fb549ad5dd4d0eb0a83c06ec23f81c36224fa028f0351decb7d82288b716a6453cbf00ad373845
diff --git a/app-misc/asciinema/asciinema-2.3.0.ebuild b/app-misc/asciinema/asciinema-2.3.0.ebuild
new file mode 100644
index 000000000000..d96b9a9376a4
--- /dev/null
+++ b/app-misc/asciinema/asciinema-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Command line recorder for asciinema.org service"
+HOMEPAGE="https://asciinema.org/ https://pypi.org/project/asciinema/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/asciinema-2.2.0-setup.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i -e "s|share/doc/asciinema|&-${PVR}|" setup.cfg || die
+}