summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 09:50:04 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 09:50:04 +0100
commitdff628cf0fe7cd5cd780e3999aad8a6e5625df50 (patch)
tree48033e1b6fef2852f26b75495f10bcb35c585898
parentsys-devel/llvm: Revert "Remove 10.0.0" (diff)
downloadgentoo-dff628cf.tar.gz
gentoo-dff628cf.tar.bz2
gentoo-dff628cf.zip
sys-devel/llvm-common: Delay llvm.org_set_globals after vars
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild5
-rw-r--r--sys-devel/llvm-common/llvm-common-12.0.0.9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild
index df9cf92b47a1..4804d9640098 100644
--- a/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild
@@ -7,8 +7,6 @@ inherit llvm.org
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( llvm/utils/vim )
-llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -17,6 +15,9 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
src_install() {
insinto /usr/share/vim/vimfiles
doins -r */
diff --git a/sys-devel/llvm-common/llvm-common-12.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-12.0.0.9999.ebuild
index df9cf92b47a1..4804d9640098 100644
--- a/sys-devel/llvm-common/llvm-common-12.0.0.9999.ebuild
+++ b/sys-devel/llvm-common/llvm-common-12.0.0.9999.ebuild
@@ -7,8 +7,6 @@ inherit llvm.org
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( llvm/utils/vim )
-llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -17,6 +15,9 @@ IUSE=""
RDEPEND="!sys-devel/llvm:0"
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
src_install() {
insinto /usr/share/vim/vimfiles
doins -r */