summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-27 18:44:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-27 18:49:44 +0100
commitdfffdb997a48ae98406b70dd1d59477ace8c5546 (patch)
tree8fd4d4a8b5cfec714efa40d19df603750aba68a6
parentdev-python/more-itertools: Bump to 9.1.0 (diff)
downloadgentoo-dfffdb99.tar.gz
gentoo-dfffdb99.tar.bz2
gentoo-dfffdb99.zip
dev-python/peewee: Bump to 3.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.16.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index 981481bfb314..d9cecd3dc380 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1 +1,2 @@
DIST peewee-3.15.4.gh.tar.gz 908759 BLAKE2B 5bb53598f44c75f4b819d7aa032a2bc812f1e6de415b4cc01e22e521e4881dd409ceaf26435ddfcf08167c5193594917f23b15ae91f037fa4216d78752e77247 SHA512 9042e1c4fffac0c395500597981ab4732383c273e2b7f2b129b2b7702d9762772a219bb848a1f0aff802c468f38327f629df1c49028858451578115cf0811a13
+DIST peewee-3.16.0.gh.tar.gz 1085430 BLAKE2B 3acfbbc9d8cce7e4bd1c0027905f4ca44431f376a243adffbfadd4d3f15b4e729c4736076e8ec72c40261ca269c66d811afb6c25b9d075d5913a13869da4f4dd SHA512 f77a040831bd3189135196ede9748c92af9db21127839dfacd7712586273bdd22c688ca22bfa373805fa1b64f770b7cea850cba53e73f324f25ced1305830409
diff --git a/dev-python/peewee/peewee-3.16.0.ebuild b/dev-python/peewee/peewee-3.16.0.ebuild
new file mode 100644
index 000000000000..510db3493fa3
--- /dev/null
+++ b/dev-python/peewee/peewee-3.16.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="
+ https://github.com/coleifer/peewee/
+ https://pypi.org/project/peewee/
+"
+SRC_URI="
+ https://github.com/coleifer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}