summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-01 01:11:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-01 02:03:39 +0200
commite0078976f674e5584e44b6a470191a048f1c59d6 (patch)
treeebbcfeacb6bfee585ec8b49e4cf0cd9b0ac04be3
parentgames-strategy/freesynd: EAPI-6 bump (diff)
downloadgentoo-e0078976.tar.gz
gentoo-e0078976.tar.bz2
gentoo-e0078976.zip
games-strategy/s25rttr: EAPI-6 bump
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.8.1-cmake.patch24
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.8.1-format.patch4
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.8.1-soundconverter.patch4
-rw-r--r--games-strategy/s25rttr/s25rttr-0.8.1-r3.ebuild17
4 files changed, 24 insertions, 25 deletions
diff --git a/games-strategy/s25rttr/files/s25rttr-0.8.1-cmake.patch b/games-strategy/s25rttr/files/s25rttr-0.8.1-cmake.patch
index d8cdfedbb9a0..14f2edb52df5 100644
--- a/games-strategy/s25rttr/files/s25rttr-0.8.1-cmake.patch
+++ b/games-strategy/s25rttr/files/s25rttr-0.8.1-cmake.patch
@@ -4,8 +4,8 @@ Date: Fri Oct 5 13:33:05 UTC 2012
make build system gentoo-compatible
provide options for SDL and GLFW video drivers
---- CMakeLists.txt
-+++ CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -19,12 +19,19 @@
################################################################################
@@ -83,8 +83,8 @@ provide options for SDL and GLFW video drivers
INSTALL(CODE "INCLUDE(src/cmake_install.cmake)")
# and then dont let him install anything
---- driver/video/CMakeLists.txt
-+++ driver/video/CMakeLists.txt
+--- a/driver/video/CMakeLists.txt
++++ b/driver/video/CMakeLists.txt
@@ -3,7 +3,11 @@
#################################################################################
@@ -99,8 +99,8 @@ provide options for SDL and GLFW video drivers
+ENDIF(BUILD_SDL_DRIVER)
#################################################################################
---- driver/video/SDL/src/CMakeLists.txt
-+++ driver/video/SDL/src/CMakeLists.txt
+--- a/driver/video/SDL/src/CMakeLists.txt
++++ b/driver/video/SDL/src/CMakeLists.txt
@@ -30,9 +30,9 @@
ADD_CUSTOM_COMMAND(TARGET videoSDL POST_BUILD COMMAND ln -fvs SDL/src/${SL_PREFIX}videoSDL${CMAKE_SHARED_LIBRARY_SUFFIX} ../../videoSDL${CMAKE_SHARED_LIBRARY_SUFFIX})
@@ -114,8 +114,8 @@ provide options for SDL and GLFW video drivers
)
ELSE (SDL_FOUND)
MESSAGE(WARNING ": SDL library not found: Not building SDL videodriver")
---- driver/video/GLFW/src/CMakeLists.txt
-+++ driver/video/GLFW/src/CMakeLists.txt
+--- a/driver/video/GLFW/src/CMakeLists.txt
++++ b/driver/video/GLFW/src/CMakeLists.txt
@@ -2,7 +2,7 @@
### $Id$
#################################################################################
@@ -133,8 +133,8 @@ provide options for SDL and GLFW video drivers
+ENDIF ("${COMPILEFOR}" STREQUAL "linux" )
#################################################################################
---- driver/audio/SDL/src/CMakeLists.txt
-+++ driver/audio/SDL/src/CMakeLists.txt
+--- a/driver/audio/SDL/src/CMakeLists.txt
++++ b/driver/audio/SDL/src/CMakeLists.txt
@@ -34,9 +34,9 @@
ADD_CUSTOM_COMMAND(TARGET audioSDL POST_BUILD COMMAND ln -fvs SDL/src/${SL_PREFIX}audioSDL${CMAKE_SHARED_LIBRARY_SUFFIX} ../../audioSDL${CMAKE_SHARED_LIBRARY_SUFFIX})
@@ -148,8 +148,8 @@ provide options for SDL and GLFW video drivers
)
ELSE (SDLMIXER_FOUND)
MESSAGE(WARNING ": SDL_mixer library not found: Not building SDL audiodriver")
---- build_paths.h.cmake
-+++ build_paths.h.cmake
+--- a/build_paths.h.cmake
++++ b/build_paths.h.cmake
@@ -41,6 +41,7 @@
// set game directory (normal $(datadir)/s25rttr/S2)
diff --git a/games-strategy/s25rttr/files/s25rttr-0.8.1-format.patch b/games-strategy/s25rttr/files/s25rttr-0.8.1-format.patch
index 588a755e829c..3d50543b9c0e 100644
--- a/games-strategy/s25rttr/files/s25rttr-0.8.1-format.patch
+++ b/games-strategy/s25rttr/files/s25rttr-0.8.1-format.patch
@@ -1,5 +1,5 @@
---- src/dskGameInterface.cpp.old 2016-02-15 21:11:58.308899794 +0100
-+++ src/dskGameInterface.cpp 2016-02-15 21:12:24.564433584 +0100
+--- a/src/dskGameInterface.cpp.old 2016-02-15 21:11:58.308899794 +0100
++++ b/src/dskGameInterface.cpp 2016-02-15 21:12:24.564433584 +0100
@@ -1349,7 +1349,7 @@
snprintf(text, sizeof(text), _("Team victory! '%s' and '%s' and '%s' and '%s' are the winners!"), GameClient::inst().GetPlayer(winners[0])->name.c_str(),GameClient::inst().GetPlayer(winners[1])->name.c_str(),GameClient::inst().GetPlayer(winners[2])->name.c_str(),GameClient::inst().GetPlayer(winners[3])->name.c_str());
break;
diff --git a/games-strategy/s25rttr/files/s25rttr-0.8.1-soundconverter.patch b/games-strategy/s25rttr/files/s25rttr-0.8.1-soundconverter.patch
index 493d7cb404be..1cc7686b850d 100644
--- a/games-strategy/s25rttr/files/s25rttr-0.8.1-soundconverter.patch
+++ b/games-strategy/s25rttr/files/s25rttr-0.8.1-soundconverter.patch
@@ -4,8 +4,8 @@ Date: Mon Apr 30 20:42:28 UTC 2012
relocate executables sound-convert and s-c_resample which get installed
into datadir by default
---- libutil/src/files.h
-+++ libutil/src/files.h
+--- a/libutil/src/files.h
++++ b/libutil/src/files.h
@@ -140,7 +140,7 @@
/* 54 */RTTRDIR "", // unbenutzt
/* 55 */SETTINGSDIR "/LSTS/SOUND.LST", // Die konvertierte sound.lst
diff --git a/games-strategy/s25rttr/s25rttr-0.8.1-r3.ebuild b/games-strategy/s25rttr/s25rttr-0.8.1-r3.ebuild
index 00187684759d..47531d7e1d95 100644
--- a/games-strategy/s25rttr/s25rttr-0.8.1-r3.ebuild
+++ b/games-strategy/s25rttr/s25rttr-0.8.1-r3.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils cmake-utils gnome2-utils readme.gentoo-r1
+EAPI=6
+
+inherit cmake-utils desktop gnome2-utils readme.gentoo-r1
DESCRIPTION="Open Source remake of The Settlers II game (needs original game files)"
HOMEPAGE="https://www.siedler25.org/"
@@ -29,6 +30,10 @@ DEPEND="${RDEPEND}
sys-devel/gettext
"
+DOCS=( RTTR/texte/{keyboardlayout.txt,readme.txt} )
+
+DOC_CONTENTS="Copy your Settlers2 game files into ~/.${PN}/S2"
+
PATCHES=(
"${FILESDIR}"/${P}-cmake.patch
"${FILESDIR}"/${P}-soundconverter.patch
@@ -39,8 +44,6 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc6.patch
)
-DOC_CONTENTS="Copy your Settlers2 game files into ~/.${PN}/S2"
-
src_configure() {
local arch
case ${ARCH} in
@@ -94,14 +97,10 @@ src_install() {
dobin src/s25client
make_desktop_entry "s25client" "Settlers RTTR" "${PN}"
- dodoc RTTR/texte/{keyboardlayout.txt,readme.txt}
+ einstalldocs
readme.gentoo_create_doc
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
gnome2_icon_cache_update
readme.gentoo_print_elog