summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-03 21:12:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-03 21:18:41 +0200
commite0284311bc7828aa6b3d9e5d0a62eb1bd199dfc4 (patch)
tree616aa117c24d4e63ccc6c69e336b4506be1e30e4
parentgnome-extra/gnome-shell-extension-appindicator: Bump to 41 (diff)
downloadgentoo-e0284311.tar.gz
gentoo-e0284311.tar.bz2
gentoo-e0284311.zip
dev-python/python-stdnum: Bump to 1.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-stdnum/Manifest1
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.17.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index 2a08b34b76d9..7440cbf7ab49 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1 +1,2 @@
DIST python-stdnum-1.16.tar.gz 1039599 BLAKE2B 98197fca412371757b7e7ec242d30d5fc43352b9eba7677aeb3a475dbe7a379c4f88797192b8e5de97493186562d1d21347703643be7798316e22f28c6a144bf SHA512 29ad92a8d1d3267c56e3d128700611cbfe3bc7a27a1420bfe62851f110f3f23b1d8927771588ef043aba366913bf7a5b0eb72896ee50343f3adf72cdb071415b
+DIST python-stdnum-1.17.tar.gz 1068804 BLAKE2B eaef8d0016f7e836226a6d83d4b54d507477d333af8572f59f24eba44f3a24bedc4d0b7d3492e7a5a64d9ceff77e296bda2876f976aab46cdb27989d0dd80df3 SHA512 9ddec525ea153e3066f205ee70602a59821e793f9ffde66a4b01511daf9a559a3a42082a99bddf69c1159a27b2d9e64d91f8a65ee283a2d7da473d766ce0e711
diff --git a/dev-python/python-stdnum/python-stdnum-1.17.ebuild b/dev-python/python-stdnum/python-stdnum-1.17.ebuild
new file mode 100644
index 000000000000..cced3449d63b
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.17.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="https://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ )
+ )"
+
+src_prepare() {
+ sed -i -e '/with-coverage/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+distutils_enable_tests nose