summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 07:33:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 08:25:43 +0200
commite03bb5f0d066a541e080d934d7e0901d11929503 (patch)
treeb34e3289d3347c10e12b4c11db1be38769ef77e5
parentdev-python/typing-extensions: Bump to 4.12.0_rc1 (diff)
downloadgentoo-e03bb5f0d066a541e080d934d7e0901d11929503.tar.gz
gentoo-e03bb5f0d066a541e080d934d7e0901d11929503.tar.bz2
gentoo-e03bb5f0d066a541e080d934d7e0901d11929503.zip
dev-python/notebook: Bump to 7.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/notebook/Manifest1
-rw-r--r--dev-python/notebook/notebook-7.2.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/notebook/Manifest b/dev-python/notebook/Manifest
index 8d89e9804f54..d35fa6782971 100644
--- a/dev-python/notebook/Manifest
+++ b/dev-python/notebook/Manifest
@@ -1 +1,2 @@
DIST notebook-7.1.3.tar.gz 4897695 BLAKE2B ed43c72cf9cc3a9c96e71aa62a2079f2fcd7f6eed3469794a78673eeb0afb8bf2cabd3c3f1f9cfed7270ff02d78c6ba10cbc3785cfac82cac5083b8c8194cfc7 SHA512 596a35b718c222f960023f31c9a3c85661622d7aaa901abb81569dc465cfaf5aba137caa1c046b7b18d5e6b5ed59e0bc3849b03e74c3e45f7344adcfdb95f594
+DIST notebook-7.2.0.tar.gz 4946565 BLAKE2B f29d784c972a2b84b84c67e0e0a225e933468c1097c698690e68f99bd5ace98765d4c0ff5146e4cd0b3be3db0b0affd5a8a41ded262b8ffe50304594cd0ae2ee SHA512 6d76d67ea02493c04287a5571f8f817cf3a4072635995bde3ae7695cd00926519f20ae44a267a38b7b65578be507103f895137e37360c93bf4219b2e8f134935
diff --git a/dev-python/notebook/notebook-7.2.0.ebuild b/dev-python/notebook/notebook-7.2.0.ebuild
new file mode 100644
index 000000000000..49097b1c08f3
--- /dev/null
+++ b/dev-python/notebook/notebook-7.2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/notebook/
+ https://pypi.org/project/notebook/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-4.2.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.27.1[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-shim-0.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/nbval[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}